containerd CRI plugin: Insecure handling of image volumes
CVE-2022-23648GHSA-crp2-qrr5-8pq7
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/containerd/containerd 1.6.1, 1.5.10, 1.4.13), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Go github.com/containerd/containerd
- Affected
- < 1.4.13>= 1.5.0, < 1.5.10>= 1.6.0, < 1.6.1
- Fixed in
- 1.4.13, 1.6.1, 1.5.10
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-crp2-qrr5-8pq7 lists affected ranges: Go github.com/containerd/containerd >=0 =1.5.0 =1.6.0 <1.6.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
- EPSS
- CVE-2022-23648: 27.39% estimated exploitation activity in the next 30 days; percentile 98.07 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact A bug was found in containerd where containers launched through containerd’s CRI implementation with a specially-crafted image configuration could gain access to read-only copies of arbitrary files and directories on the host. This may bypass any policy-based enforcement on container setup (including a Kubernetes Pod Security Policy) and expose potentially sensitive information. Kubernetes and crictl can both be configured to use containerd’s CRI implementation. Patches This bug has been fixed in containerd 1.6.1, 1.5.10 and 1.4.13. Users should update to these versions to resolve the issue. Workarounds Ensure that only trusted images are used. Credits The containerd project would like to thank Felix Wilhelm of Google Project Zero for responsibly disclosing this issue in accordance with the containerd security policy. For more information If you have any questions or comments about this advisory: Open an issue in containerd Email us at security@containerd.io
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-crp2-qrr5-8pq7
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2022-23648 Advisory: containerd CRI plugin: Insecure handling of image volumes IDs: CVE-2022-23648, GHSA-crp2-qrr5-8pq7 Record: https://patchnext.com/advisories/cve-2022-23648 (revision 1, source checked 26 Oct 2026, 15:03 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: github.com/containerd/containerd 1.6.1, 1.5.10, 1.4.13. A vendor fix does not mean a deployment is fixed. ## Affected components - Go github.com/containerd/containerd: affected < 1.4.13; >= 1.5.0, < 1.5.10; >= 1.6.0, < 1.6.1; fixed in 1.4.13, 1.6.1, 1.5.10 ## Suggested inspection (read-only) - Go github.com/containerd/containerd: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on github.com/containerd/containerd. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-crp2-qrr5-8pq7 (GitHub-reviewed advisory GHSA-crp2-qrr5-8pq7 lists affected ranges: Go github.com/containerd/containerd >=0 =1.5.0 =1.6.0 <1.6.1) Commands are suggestions: review each one before running it.
Loading voting…