Skip to content

← Actionable
Medium, CVSS 5.9amended

Improper CSP in Image Optimization API for Next.js versions between 10.0.0 and 12.1.0

CVE-2022-23646GHSA-fmvm-x8mv-47mj

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (next 12.1.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm next

    Affected
    >= 10.0.0, < 12.1.0
    Fixed in
    12.1.0

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
5.9 · CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:H/A:N
EPSS
  • CVE-2022-23646: 1.80% estimated exploitation activity in the next 30 days; percentile 78.45 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Next.js is a React framework. Starting with version 10.0.0 and prior to version 12.1.0, Next.js is vulnerable to User Interface (UI) Misrepresentation of Critical Information. In order to be affected, the next.config.js file must have an images.domains array assigned and the image host assigned in images.domains must allow user-provided SVG. If the next.config.js file has images.loader assigned to something other than default, the instance is not affected. Version 12.1.0 contains a patch for this issue. As a workaround, change next.config.js to use a different loader configuration other than the default. Impact - Affected: All of the following must be true to be affected - Next.js between version 10.0.0 and 12.0.10 - The next.config.js file has images.domains array assigned - The image host assigned in images.domains allows user-provided SVG - Not affected: The next.config.js file has images.loader assigned to something other than default Patches Next.js 12.1.0 Workarounds Change…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-fmvm-x8mv-47mj

  2. Revision 1 · created ·

    Published from osv record GHSA-fmvm-x8mv-47mj

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2022-23646

Advisory: Improper CSP in Image Optimization API for Next.js versions between 10.0.0 and 12.1.0
IDs: CVE-2022-23646, GHSA-fmvm-x8mv-47mj
Record: https://patchnext.com/advisories/cve-2022-23646 (revision 2, source checked 26 Oct 2026, 12:21 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.9)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: next 12.1.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm next: affected >= 10.0.0, < 12.1.0; fixed in 12.1.0

## Suggested inspection (read-only)
- `npm ls next --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on next.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-fmvm-x8mv-47mj (OSV record GHSA-fmvm-x8mv-47mj lists affected ranges: npm next >=10.0.0 <12.1.0 (fixed))
- Verified: https://github.com/advisories/GHSA-fmvm-x8mv-47mj (GitHub-reviewed advisory GHSA-fmvm-x8mv-47mj lists affected ranges: npm next >=10.0.0 <12.1.0)

Commands are suggestions: review each one before running it.

Loading voting…