Skip to content

← Actionable
Medium, CVSS 6.3

Incorrect Calculation in github.com/open-policy-agent/opa

CVE-2022-23628GHSA-hcw3-j74m-qc58

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/open-policy-agent/opa 0.37.2), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
6.3 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:L
EPSS
  • CVE-2022-23628: 1.03% estimated exploitation activity in the next 30 days; percentile 63.65 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact Under certain conditions, pretty-printing an AST that contains synthetic nodes could change the logic of some statements by reordering array literals. Example of policies impacted are those that parse and compare web paths, see the example below. All of these three conditions have to be met to create an adverse effect: 1. An AST of Rego had to be created programmatically such that it ends up containing terms without a location (such as wildcard variables). 2. The AST had to be pretty-printed using the github.com/open-policy-agent/opa/format package. 3. The result of the pretty-printing had to be parsed and evaluated again via an OPA instance using the bundles, or the Golang packages. If any of these three conditions are not met, you are not affected. Notably, all three would be true if using optimized bundles, i.e. bundles created with opa build -O=1 or higher. In that case, the optimizer would fulfil condition (1.), the result of that would be pretty-printed when writing the…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-hcw3-j74m-qc58

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2022-23628

Advisory: Incorrect Calculation in github.com/open-policy-agent/opa
IDs: CVE-2022-23628, GHSA-hcw3-j74m-qc58
Record: https://patchnext.com/advisories/cve-2022-23628 (revision 1, source checked 26 Oct 2026, 15:04 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: github.com/open-policy-agent/opa 0.37.2. A vendor fix does not mean a deployment is fixed.

## Affected components
- Go github.com/open-policy-agent/opa: affected >= 0.33.1, < 0.37.2; fixed in 0.37.2

## Suggested inspection (read-only)
- Go github.com/open-policy-agent/opa: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on github.com/open-policy-agent/opa.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-hcw3-j74m-qc58 (GitHub-reviewed advisory GHSA-hcw3-j74m-qc58 lists affected ranges: Go github.com/open-policy-agent/opa >=0.33.1 <0.37.2)

Commands are suggestions: review each one before running it.

Loading voting…