Missing authorization in xwiki-platform
CVE-2022-23621GHSA-2jhm-qp48-hv5j
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.xwiki.platform:xwiki-platform-oldcore 13.7-rc-1, 13.4.3, 12.10.9), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven org.xwiki.platform:xwiki-platform-oldcore
- Affected
- >= 13.6-rc-1, <= 13.6>= 13.0.0, < 13.4.3< 12.10.9
- Fixed in
- 12.10.9, 13.7-rc-1, 13.4.3
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-2jhm-qp48-hv5j lists affected ranges: Maven org.xwiki.platform:xwiki-platform-oldcore >=13.6-rc-1 =13.0.0 =0 <12.10.9
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 5.5 · CVSS:3.1/AV:N/AC:H/PR:H/UI:N/S:U/C:L/I:L/A:H
- EPSS
- CVE-2022-23621: 0.94% estimated exploitation activity in the next 30 days; percentile 60.83 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact Any user with SCRIPT right (EDIT right before XWiki 7.4) can read any file located in the XWiki WAR (for example xwiki.cfg and xwiki.properties) through XWiki#invokeServletAndReturnAsString: Patches It has been patched in XWiki versions 12.10.9, 13.4.3 and 13.7-rc-1. Workarounds The only workaround is to give SCRIPT right only to trusted users. References https://jira.xwiki.org/browse/XWIKI-18870 For more information If you have any questions or comments about this advisory: Open an issue in Jira XWiki Email us at our security mailing list
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-2jhm-qp48-hv5j
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2022-23621 Advisory: Missing authorization in xwiki-platform IDs: CVE-2022-23621, GHSA-2jhm-qp48-hv5j Record: https://patchnext.com/advisories/cve-2022-23621 (revision 1, source checked 26 Oct 2026, 16:11 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: org.xwiki.platform:xwiki-platform-oldcore 13.7-rc-1, 13.4.3, 12.10.9. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven org.xwiki.platform:xwiki-platform-oldcore: affected >= 13.6-rc-1, <= 13.6; >= 13.0.0, < 13.4.3; < 12.10.9; fixed in 12.10.9, 13.7-rc-1, 13.4.3 ## Suggested inspection (read-only) - Maven org.xwiki.platform:xwiki-platform-oldcore: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on org.xwiki.platform:xwiki-platform-oldcore. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-2jhm-qp48-hv5j (GitHub-reviewed advisory GHSA-2jhm-qp48-hv5j lists affected ranges: Maven org.xwiki.platform:xwiki-platform-oldcore >=13.6-rc-1 =13.0.0 =0 <12.10.9) Commands are suggestions: review each one before running it.
Loading voting…