CSRF token missing in Symfony
CVE-2022-23601GHSA-vvmr-8829-6whx
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (symfony/framework-bundle 6.0.4, 5.4.4, 5.3.15), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist symfony/framework-bundle
- Affected
- >= 5.3.14, <= 5.3.14>= 5.4.3, <= 5.4.3>= 6.0.3, <= 6.0.3
- Fixed in
- 5.3.15, 5.4.4, 6.0.4
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-vvmr-8829-6whx lists affected ranges: Packagist symfony/framework-bundle >=5.3.14 =5.4.3 =6.0.3 <=6.0.3
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 8.1 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:N
- EPSS
- CVE-2022-23601: 0.57% estimated exploitation activity in the next 30 days; percentile 47.02 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Description ----------- The Symfony form component provides a CSRF protection mechanism by using a random token injected in the form and using the session to store and control the token submitted by the user. When using the FrameworkBundle, this protection can be enabled or disabled with the configuration. If the configuration is not specified, by default, the mechanism is enabled as long as the session is enabled. In a recent change in the way the configuration is loaded, the default behavior has been dropped and, as a result, the CSRF protection is not enabled in form when not explicitly enabled, which makes the application sensible to CSRF attacks. Resolution ---------- Symfony restored the default configuration to enable the CSRF protection by default. The patch for this issue is available here for branch 5.3. Credits ------- We would like to thank Catalin Dan and David Lochner for reporting the issue and Jérémy Derussé for fixing the issue.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-vvmr-8829-6whx
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2022-23601 Advisory: CSRF token missing in Symfony IDs: CVE-2022-23601, GHSA-vvmr-8829-6whx Record: https://patchnext.com/advisories/cve-2022-23601 (revision 1, source checked 26 Oct 2026, 14:19 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.1) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: symfony/framework-bundle 6.0.4, 5.4.4, 5.3.15. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist symfony/framework-bundle: affected >= 5.3.14, <= 5.3.14; >= 5.4.3, <= 5.4.3; >= 6.0.3, <= 6.0.3; fixed in 5.3.15, 5.4.4, 6.0.4 ## Suggested inspection (read-only) - Packagist symfony/framework-bundle: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on symfony/framework-bundle. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-vvmr-8829-6whx (GitHub-reviewed advisory GHSA-vvmr-8829-6whx lists affected ranges: Packagist symfony/framework-bundle >=5.3.14 =5.4.3 =6.0.3 <=6.0.3) Commands are suggestions: review each one before running it.
Loading voting…