Limited ability to spoof SAML authentication with missing audience verification in Fleet
CVE-2022-23600GHSA-ch68-7cf4-35vr
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/fleetdm/fleet/v4 4.9.1), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Go github.com/fleetdm/fleet/v4
- Affected
- < 4.9.1
- Fixed in
- 4.9.1
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-ch68-7cf4-35vr lists affected ranges: Go github.com/fleetdm/fleet/v4 >=0 <4.9.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 5.3 · CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:N/A:N
- EPSS
- CVE-2022-23600: 0.89% estimated exploitation activity in the next 30 days; percentile 59.50 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact This impacts deployments using SAML SSO in two specific cases: 1. A malicious or compromised Service Provider (SP) could reuse the SAML response to log into Fleet as a user -- only if the user has an account with the same email in Fleet, and the user signs into the malicious SP via SAML SSO from the same Identity Provider (IdP) configured with Fleet. 2. A user with an account in Fleet could reuse a SAML response intended for another SP to log into Fleet. This is only a concern if the user is blocked from Fleet in the IdP, but continues to have an account in Fleet. If the user is blocked from the IdP entirely, this cannot be exploited. Patches Fleet 4.9.1 resolves this issue. Workarounds and good practices Reduce the length of sessions on your IdP to reduce the window for malicious re-use. Limit the amount of SAML Service Providers/Applications used by user accounts with access to Fleet. When removing access to Fleet in the IdP, delete the Fleet user from Fleet as well. For…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-ch68-7cf4-35vr
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2022-23600 Advisory: Limited ability to spoof SAML authentication with missing audience verification in Fleet IDs: CVE-2022-23600, GHSA-ch68-7cf4-35vr Record: https://patchnext.com/advisories/cve-2022-23600 (revision 1, source checked 26 Oct 2026, 14:55 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: github.com/fleetdm/fleet/v4 4.9.1. A vendor fix does not mean a deployment is fixed. ## Affected components - Go github.com/fleetdm/fleet/v4: affected < 4.9.1; fixed in 4.9.1 ## Suggested inspection (read-only) - Go github.com/fleetdm/fleet/v4: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on github.com/fleetdm/fleet/v4. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-ch68-7cf4-35vr (GitHub-reviewed advisory GHSA-ch68-7cf4-35vr lists affected ranges: Go github.com/fleetdm/fleet/v4 >=0 <4.9.1) Commands are suggestions: review each one before running it.
Loading voting…