Cross-site Scripting when rendering error messages in laminas-form
CVE-2022-23598GHSA-jq4p-mq33-w375
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (laminas/laminas-form 3.1.1, 3.0.2, 2.17.1), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist laminas/laminas-form
- Affected
- >= 3.1.0, < 3.1.1>= 3.0.0, < 3.0.2< 2.17.1
- Fixed in
- 3.0.2, 3.1.1, 2.17.1
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-jq4p-mq33-w375 lists affected ranges: Packagist laminas/laminas-form >=3.1.0 =3.0.0 =0 <2.17.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 6.1 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
- EPSS
- CVE-2022-23598: 0.99% estimated exploitation activity in the next 30 days; percentile 62.55 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact When rendering validation error messages via the formElementErrors() view helper shipped with laminas-form, many messages will contain the submitted value. However, in vulnerable versions of laminas-form, the value was not being escaped for HTML contexts, which can potentially lead to a Reflected Cross-Site Scripting (XSS) attack. Patches The following versions were issued to mitigate the vulnerability: - 2.17.1 - 3.0.2 - 3.1.1 Workarounds At the top of a view script where you call the formElementErrors() view helper, place the following code: Before calling formElementErrors() with a form, fieldset, or element, call the above closure as follows For more information If you have any questions or comments about this advisory: Open an issue Email us at security@getlaminas.org
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-jq4p-mq33-w375
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2022-23598 Advisory: Cross-site Scripting when rendering error messages in laminas-form IDs: CVE-2022-23598, GHSA-jq4p-mq33-w375 Record: https://patchnext.com/advisories/cve-2022-23598 (revision 1, source checked 26 Oct 2026, 14:05 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.1) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: laminas/laminas-form 3.1.1, 3.0.2, 2.17.1. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist laminas/laminas-form: affected >= 3.1.0, < 3.1.1; >= 3.0.0, < 3.0.2; < 2.17.1; fixed in 3.0.2, 3.1.1, 2.17.1 ## Suggested inspection (read-only) - Packagist laminas/laminas-form: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on laminas/laminas-form. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-jq4p-mq33-w375 (GitHub-reviewed advisory GHSA-jq4p-mq33-w375 lists affected ranges: Packagist laminas/laminas-form >=3.1.0 =3.0.0 =0 <2.17.1) Commands are suggestions: review each one before running it.
Loading voting…