Out of bounds read in Tensorflow
CVE-2022-23592GHSA-vq36-27g6-p492
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (tensorflow 2.8.0; tensorflow-gpu 2.8.0; tensorflow-cpu 2.8.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI tensorflow
- Affected
- >= 2.8.0rc0, <= 2.8.0rc0
- Fixed in
- 2.8.0
PyPI tensorflow-gpu
- Affected
- >= 2.8.0rc0, <= 2.8.0rc0
- Fixed in
- 2.8.0
PyPI tensorflow-cpu
- Affected
- >= 2.8.0rc0, <= 2.8.0rc0
- Fixed in
- 2.8.0
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record PYSEC-2022-101 lists affected ranges: PyPI tensorflow-cpu >=2.7.0 <2.8.0 (fixed)
VerifiedObserved Structured OSV record; not marked as GitHub-reviewed.
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record PYSEC-2022-156 lists affected ranges: PyPI tensorflow-gpu >=2.7.0 <2.8.0 (fixed)
VerifiedObserved Structured OSV record; not marked as GitHub-reviewed.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-vq36-27g6-p492 lists affected ranges: PyPI tensorflow >=2.8.0rc0 =2.8.0rc0 =2.8.0rc0 <=2.8.0rc0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 7.2 · CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:N/VA:H/SC:N/SI:N/SA:N · score source
- EPSS
- CVE-2022-23592: 0.86% estimated exploitation activity in the next 30 days; percentile 58.71 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact TensorFlow's type inference can cause a heap OOB read as the bounds checking is done in a DCHECK (which is a no-op during production): An attacker can control inputidx such that ix would be larger than the number of values in nodet.args. Patches We have patched the issue in GitHub commit c99d98cd189839dcf51aee94e7437b54b31f8abd. The fix will be included in TensorFlow 2.8.0. This is the only affected version. For more information Please consult our security guide for more information regarding the security model and how to contact us with issues and questions.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 4 · amended ·
Amended from ghsa record GHSA-vq36-27g6-p492
- Revision 3 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 2 · amended ·
Amended from osv record PYSEC-2022-156
- Revision 1 · created ·
Published from osv record PYSEC-2022-101
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2022-23592 Advisory: Out of bounds read in Tensorflow IDs: CVE-2022-23592, GHSA-vq36-27g6-p492 Record: https://patchnext.com/advisories/cve-2022-23592 (revision 4, source checked 26 Oct 2026, 13:26 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.2) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: tensorflow 2.8.0; tensorflow-gpu 2.8.0; tensorflow-cpu 2.8.0. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI tensorflow: affected >= 2.8.0rc0, <= 2.8.0rc0; fixed in 2.8.0 - PyPI tensorflow-gpu: affected >= 2.8.0rc0, <= 2.8.0rc0; fixed in 2.8.0 - PyPI tensorflow-cpu: affected >= 2.8.0rc0, <= 2.8.0rc0; fixed in 2.8.0 ## Suggested inspection (read-only) - `python -m pip show tensorflow`: prints the installed version. Run with the environment that serves production active. - `python -m pip show tensorflow-gpu`: prints the installed version. Run with the environment that serves production active. - `python -m pip show tensorflow-cpu`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on tensorflow, tensorflow-gpu, tensorflow-cpu. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/PYSEC-2022-101 (OSV record PYSEC-2022-101 lists affected ranges: PyPI tensorflow-cpu >=2.7.0 <2.8.0 (fixed)) - Verified: https://osv.dev/vulnerability/PYSEC-2022-156 (OSV record PYSEC-2022-156 lists affected ranges: PyPI tensorflow-gpu >=2.7.0 <2.8.0 (fixed)) - Verified: https://github.com/advisories/GHSA-vq36-27g6-p492 (GitHub-reviewed advisory GHSA-vq36-27g6-p492 lists affected ranges: PyPI tensorflow >=2.8.0rc0 =2.8.0rc0 =2.8.0rc0 <=2.8.0rc0) Commands are suggestions: review each one before running it.
Loading voting…