Skip to content

← Actionable
Medium, CVSS 6.5amended

CHECK-failures during Grappler's IsSimplifiableReshape in Tensorflow

CVE-2022-23581GHSA-fq86-3f29-px2c

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (tensorflow 2.7.1, 2.6.3, 2.5.3; tensorflow-gpu 2.7.1, 2.6.3, 2.5.3; tensorflow-cpu 2.7.1, 2.6.3, 2.5.3), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI tensorflow

    Affected
    < 2.5.3>= 2.6.0, < 2.6.3>= 2.7.0, <= 2.7.0
    Fixed in
    2.5.3, 2.7.1, 2.6.3
  • PyPI tensorflow-gpu

    Affected
    < 2.5.3>= 2.6.0, < 2.6.3>= 2.7.0, <= 2.7.0
    Fixed in
    2.5.3, 2.7.1, 2.6.3
  • PyPI tensorflow-cpu

    Affected
    < 2.5.3>= 2.6.0, < 2.6.3>= 2.7.0, <= 2.7.0
    Fixed in
    2.5.3, 2.7.1, 2.6.3

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
6.5 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H
EPSS
  • CVE-2022-23581: 1.16% estimated exploitation activity in the next 30 days; percentile 67.18 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact The Grappler optimizer in TensorFlow can be used to cause a denial of service by altering a SavedModel such that IsSimplifiableReshape would trigger CHECK failures. Patches We have patched the issue in GitHub commits ebc1a2ffe5a7573d905e99bd0ee3568ee07c12c1, 1fb27733f943295d874417630edd3b38b34ce082, and 240655511cd3e701155f944a972db71b6c0b1bb6. The fix will be included in TensorFlow 2.8.0. We will also cherrypick this commit on TensorFlow 2.7.1, TensorFlow 2.6.3, and TensorFlow 2.5.3, as these are also affected and still in supported range. For more information Please consult our security guide for more information regarding the security model and how to contact us with issues and questions.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-fq86-3f29-px2c

  2. Revision 1 · created ·

    Published from osv record GHSA-fq86-3f29-px2c

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2022-23581

Advisory: `CHECK`-failures during Grappler's `IsSimplifiableReshape` in Tensorflow
IDs: CVE-2022-23581, GHSA-fq86-3f29-px2c
Record: https://patchnext.com/advisories/cve-2022-23581 (revision 2, source checked 26 Oct 2026, 13:26 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: tensorflow 2.7.1, 2.6.3, 2.5.3; tensorflow-gpu 2.7.1, 2.6.3, 2.5.3; tensorflow-cpu 2.7.1, 2.6.3, 2.5.3. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI tensorflow: affected < 2.5.3; >= 2.6.0, < 2.6.3; >= 2.7.0, <= 2.7.0; fixed in 2.5.3, 2.7.1, 2.6.3
- PyPI tensorflow-gpu: affected < 2.5.3; >= 2.6.0, < 2.6.3; >= 2.7.0, <= 2.7.0; fixed in 2.5.3, 2.7.1, 2.6.3
- PyPI tensorflow-cpu: affected < 2.5.3; >= 2.6.0, < 2.6.3; >= 2.7.0, <= 2.7.0; fixed in 2.5.3, 2.7.1, 2.6.3

## Suggested inspection (read-only)
- `python -m pip show tensorflow`: prints the installed version. Run with the environment that serves production active.
- `python -m pip show tensorflow-gpu`: prints the installed version. Run with the environment that serves production active.
- `python -m pip show tensorflow-cpu`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on tensorflow, tensorflow-gpu, tensorflow-cpu.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-fq86-3f29-px2c (OSV record GHSA-fq86-3f29-px2c lists affected ranges: PyPI tensorflow >=0 =2.6.0 =2.7.0 =0 =2.6.0 =2.7.0 =0 =2.6.0 =2.7.0 <2.7.1 (fixed))
- Verified: https://github.com/advisories/GHSA-fq86-3f29-px2c (GitHub-reviewed advisory GHSA-fq86-3f29-px2c lists affected ranges: PyPI tensorflow >=0 =2.6.0 =2.7.0 =0 =2.6.0 =2.7.0 =0 =2.6.0 =2.7.0 <=2.7.0)

Commands are suggestions: review each one before running it.

Loading voting…