Skip to content

← Actionable
Unrated

OpenFGA Authorization Bypass

CVE-2022-23542GHSA-m3q4-7qmj-657m

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/openfga/openfga 0.3.1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
not scored
EPSS
  • CVE-2022-23542: 0.99% estimated exploitation activity in the next 30 days; percentile 62.52 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Overview During our internal security assessment, it was discovered that OpenFGA versions v0.3.0 is vulnerable to authorization bypass under certain conditions. Am I Affected? You are affected by this vulnerability if all of the following applies: 1. You are using OpenFGA v0.3.0 2. You created a model using modeling language v1.1 that applies a type restriction to an object e.g. define viewer: [user] 3. You created tuples based on the aforementioned model, e.g. document:1#viewer@user:jon 4. You updated the previous model by adding a new type and replacing the previous restriction with the newly added type e.g. define viewer: [employee] 5. You use the tuples created against the first model (step 3) and issue checks against the updated model e.g. user=user:jon, relation=viewer, object:document:1 How to fix that? Upgrade to version v0.3.1 Backward Compatibility This update is backward compatible.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-m3q4-7qmj-657m

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2022-23542

Advisory: OpenFGA Authorization Bypass
IDs: CVE-2022-23542, GHSA-m3q4-7qmj-657m
Record: https://patchnext.com/advisories/cve-2022-23542 (revision 1, source checked 26 Oct 2026, 14:54 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Unrated
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: github.com/openfga/openfga 0.3.1. A vendor fix does not mean a deployment is fixed.

## Affected components
- Go github.com/openfga/openfga: affected >= 0.3.0, <= 0.3.0; fixed in 0.3.1

## Suggested inspection (read-only)
- Go github.com/openfga/openfga: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on github.com/openfga/openfga.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-m3q4-7qmj-657m (GitHub-reviewed advisory GHSA-m3q4-7qmj-657m lists affected ranges: Go github.com/openfga/openfga >=0.3.0 <=0.3.0)

Commands are suggestions: review each one before running it.

Loading voting…