Skip to content

← Actionable
High, CVSS 8.1amended

jsonwebtoken unrestricted key type could lead to legacy keys usage

CVE-2022-23539GHSA-8cf7-32gw-wr33

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (jsonwebtoken 9.0.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
8.1 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:N
EPSS
  • CVE-2022-23539: 0.52% estimated exploitation activity in the next 30 days; percentile 44.50 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Overview Versions <=8.5.1 of jsonwebtoken library could be misconfigured so that legacy, insecure key types are used for signature verification. For example, DSA keys could be used with the RS256 algorithm. Am I affected? You are affected if you are using an algorithm and a key type other than the combinations mentioned below | Key type | algorithm | |----------|------------------------------------------| | ec | ES256, ES384, ES512 | | rsa | RS256, RS384, RS512, PS256, PS384, PS512 | | rsa-pss | PS256, PS384, PS512 | And for Elliptic Curve algorithms: | alg | Curve | |-------|------------| | ES256 | prime256v1 | | ES384 | secp384r1 | | ES512 | secp521r1 | How do I fix it? Update to version 9.0.0. This version validates for asymmetric key type and algorithm combinations. Please refer to the above mentioned algorithm / key type combinations for the valid secure configuration. After updating to version 9.0.0, If you still intend to continue with signing or verifying tokens using invalid…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-8cf7-32gw-wr33

  2. Revision 1 · created ·

    Published from osv record GHSA-8cf7-32gw-wr33

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2022-23539

Advisory: jsonwebtoken unrestricted key type could lead to legacy keys usage
IDs: CVE-2022-23539, GHSA-8cf7-32gw-wr33
Record: https://patchnext.com/advisories/cve-2022-23539 (revision 2, source checked 26 Oct 2026, 12:30 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: jsonwebtoken 9.0.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm jsonwebtoken: affected <= 8.5.1; fixed in 9.0.0

## Suggested inspection (read-only)
- `npm ls jsonwebtoken --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on jsonwebtoken.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-8cf7-32gw-wr33 (OSV record GHSA-8cf7-32gw-wr33 lists affected ranges: npm jsonwebtoken >=0 <9.0.0 (fixed))
- Verified: https://github.com/advisories/GHSA-8cf7-32gw-wr33 (GitHub-reviewed advisory GHSA-8cf7-32gw-wr33 lists affected ranges: npm jsonwebtoken >=0 <=8.5.1)

Commands are suggestions: review each one before running it.

Loading voting…