org.neo4j.procedure:apoc Path Traversal Vulnerability
CVE-2022-23532GHSA-5v8v-gwmw-qw97
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.neo4j.procedure:apoc 4.4.0.12, 4.3.0.12), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven org.neo4j.procedure:apoc
- Affected
- < 4.3.0.12>= 4.4.0.0, < 4.4.0.12
- Fixed in
- 4.3.0.12, 4.4.0.12
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-5v8v-gwmw-qw97 lists affected ranges: Maven org.neo4j.procedure:apoc >=0 =4.4.0.0 <4.4.0.12
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.1 · CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:C/C:N/I:H/A:L
- EPSS
- CVE-2022-23532: 0.69% estimated exploitation activity in the next 30 days; percentile 52.80 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact A Path Traversal Vulnerability found in the apoc.export. procedures of apoc plugins in Neo4j Graph database. The issue allows a malicious actor to potentially break out of the expected directory. The vulnerability is such that files could only be created but not overwritten. For the vulnerability to be exploited, an attacker would need access to execute an arbitrary query, either by having access to an authenticated Neo4j client, or a Cypher injection vulnerability in an application. The procedure would need to have been allow listed in the neo4j configuration as well as having the apoc config apoc.export.file.enabled set to true. On a UNIX based system the following query allows arbitrary write access to the tmp folder: CALL apoc.export.csv.query('RETURN 1', 'file:///..//..//..//..//tmp/test.txt', {}) Patches The users should aim to use the latest released version compatible with their Neo4j version. The minimum versions containing patch for this vulnerability are 4.4.0.12…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-5v8v-gwmw-qw97
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2022-23532 Advisory: org.neo4j.procedure:apoc Path Traversal Vulnerability IDs: CVE-2022-23532, GHSA-5v8v-gwmw-qw97 Record: https://patchnext.com/advisories/cve-2022-23532 (revision 1, source checked 26 Oct 2026, 15:53 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.1) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: org.neo4j.procedure:apoc 4.4.0.12, 4.3.0.12. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven org.neo4j.procedure:apoc: affected < 4.3.0.12; >= 4.4.0.0, < 4.4.0.12; fixed in 4.3.0.12, 4.4.0.12 ## Suggested inspection (read-only) - Maven org.neo4j.procedure:apoc: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on org.neo4j.procedure:apoc. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-5v8v-gwmw-qw97 (GitHub-reviewed advisory GHSA-5v8v-gwmw-qw97 lists affected ranges: Maven org.neo4j.procedure:apoc >=0 =4.4.0.0 <4.4.0.12) Commands are suggestions: review each one before running it.
Loading voting…