Skip to content

← Actionable
Low, CVSS 2.3amended

GuardDog vulnerable to arbitrary file write when scanning a specially-crafted remote PyPI package

CVE-2022-23530GHSA-78m5-jpmf-ch7v

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (guarddog 0.1.8), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI guarddog

    Affected
    <= 0.1.7
    Fixed in
    0.1.8

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
2.3 · CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:P/VC:L/VI:L/VA:L/SC:L/SI:L/SA:L · score source
EPSS
  • CVE-2022-23530: 0.75% estimated exploitation activity in the next 30 days; percentile 55.06 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary Unsafe extracting using shutil.unpackarchive() from a remotely retrieved tarball may lead to writing the extracted file to an unintended destination. Details Extracting files using shutil.unpackarchive() from a potentially malicious tarball without validating that the destination file path is within the intended destination directory can cause files outside the destination directory to be overwritten. The vulnerable code snippet is between L153..158. It seems that a remotely retrieved tarball which could be with the extension .tar.gz happens to be unpacked using shutil.unpackarchive() with no destination verification/limitation of the extracted files. PoC The PoC provided showcases the risk of extracting the non-harmless text file sim4n6.txt to a parent location rather than the current folder. A Potential Attack Scenario - An attacker may craft a malicious tarball with a filename path, such as ../../../../../../../../etc/passwd, and then serve the archive remotely, thus,…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-78m5-jpmf-ch7v

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-78m5-jpmf-ch7v

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2022-23530

Advisory: GuardDog vulnerable to arbitrary file write when scanning a specially-crafted remote PyPI package
IDs: CVE-2022-23530, GHSA-78m5-jpmf-ch7v
Record: https://patchnext.com/advisories/cve-2022-23530 (revision 3, source checked 26 Oct 2026, 13:27 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Low (CVSS 2.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: guarddog 0.1.8. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI guarddog: affected <= 0.1.7; fixed in 0.1.8

## Suggested inspection (read-only)
- `python -m pip show guarddog`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on guarddog.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-78m5-jpmf-ch7v (OSV record GHSA-78m5-jpmf-ch7v lists affected ranges: PyPI guarddog >=0 <0.1.8 (fixed))
- Verified: https://github.com/advisories/GHSA-78m5-jpmf-ch7v (GitHub-reviewed advisory GHSA-78m5-jpmf-ch7v lists affected ranges: PyPI guarddog >=0 <=0.1.7)

Commands are suggestions: review each one before running it.

Loading voting…