Skip to content

← Actionable
Low, CVSS 1.9

linux-loader reading beyond EOF could lead to infinite loop

CVE-2022-23523GHSA-52h2-m2cf-9jh6

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (linux-loader 0.8.1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
1.9 · CVSS:3.1/AV:L/AC:H/PR:H/UI:N/S:U/C:N/I:N/A:L
EPSS
  • CVE-2022-23523: 0.22% estimated exploitation activity in the next 30 days; percentile 12.17 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact The linux-loader crate used the offsets and sizes provided in the ELF headers to determine the offsets to read from. If those offsets pointed beyond the end of the file this could lead to an infinite loop. Virtual Machine Monitors using the linux-loader crate could enter an infinite loop if the ELF header of the kernel they are loading was modified in a malicious manner. Patches The issue has been addressed in 0.8.1 Workarounds The issue can be mitigated by ensuring that only trusted kernel images are loaded or by verifying that the headers to not point beyond the end of the file. References See: https://github.com/rust-vmm/linux-loader/pull/125

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-52h2-m2cf-9jh6

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2022-23523

Advisory: linux-loader reading beyond EOF could lead to infinite loop
IDs: CVE-2022-23523, GHSA-52h2-m2cf-9jh6
Record: https://patchnext.com/advisories/cve-2022-23523 (revision 1, source checked 26 Oct 2026, 15:33 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Low (CVSS 1.9)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: linux-loader 0.8.1. A vendor fix does not mean a deployment is fixed.

## Affected components
- crates.io linux-loader: affected < 0.8.1; fixed in 0.8.1

## Suggested inspection (read-only)
- crates.io linux-loader: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on linux-loader.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-52h2-m2cf-9jh6 (GitHub-reviewed advisory GHSA-52h2-m2cf-9jh6 lists affected ranges: crates.io linux-loader >=0 <0.8.1)

Commands are suggestions: review each one before running it.

Loading voting…