Possible XSS vulnerability with certain configurations of rails-html-sanitizer
CVE-2022-23519GHSA-9h9g-93gc-623h
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (rails-html-sanitizer 1.4.4), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
RubyGems rails-html-sanitizer
- Affected
- < 1.4.4
- Fixed in
- 1.4.4
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-9h9g-93gc-623h lists affected ranges: RubyGems rails-html-sanitizer >=0 <1.4.4
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 6.1 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
- EPSS
- CVE-2022-23519: 1.05% estimated exploitation activity in the next 30 days; percentile 64.46 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary There is a possible XSS vulnerability with certain configurations of Rails::Html::Sanitizer. - Versions affected: ALL - Not affected: NONE - Fixed versions: 1.4.4 Impact A possible XSS vulnerability with certain configurations of Rails::Html::Sanitizer may allow an attacker to inject content if the application developer has overridden the sanitizer's allowed tags in either of the following ways: - allow both "math" and "style" elements, - or allow both "svg" and "style" elements Code is only impacted if allowed tags are being overridden. Applications may be doing this in four different ways: 1. using application configuration: see https://guides.rubyonrails.org/configuring.html#configuring-action-view 2. using a :tags option to the Action View helper sanitize: see https://api.rubyonrails.org/classes/ActionView/Helpers/SanitizeHelper.html#method-i-sanitize 3. using Rails::Html::SafeListSanitizer class method allowedtags=: 4. using a :tags options to the…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-9h9g-93gc-623h
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2022-23519 Advisory: Possible XSS vulnerability with certain configurations of rails-html-sanitizer IDs: CVE-2022-23519, GHSA-9h9g-93gc-623h Record: https://patchnext.com/advisories/cve-2022-23519 (revision 1, source checked 26 Oct 2026, 15:51 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.1) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: rails-html-sanitizer 1.4.4. A vendor fix does not mean a deployment is fixed. ## Affected components - RubyGems rails-html-sanitizer: affected < 1.4.4; fixed in 1.4.4 ## Suggested inspection (read-only) - RubyGems rails-html-sanitizer: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on rails-html-sanitizer. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-9h9g-93gc-623h (GitHub-reviewed advisory GHSA-9h9g-93gc-623h lists affected ranges: RubyGems rails-html-sanitizer >=0 <1.4.4) Commands are suggestions: review each one before running it.
Loading voting…