Skip to content

← Actionable
High, CVSS 7.7amended

@cubejs-backend/api-gateway row level security bypass

CVE-2022-23510GHSA-6jqm-3c9g-pch7

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (@cubejs-backend/api-gateway 0.31.24), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.7 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:N/A:N
EPSS
  • CVE-2022-23510: 0.97% estimated exploitation activity in the next 30 days; percentile 62.11 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact All authenticated Cube clients could bypass row-level security and run arbitrary SQL via the newly introduced /v1/sql-runner endpoint. Patches The change has been reverted in 0.31.24 Workarounds Upgrade to =0.31.24 or downgrade to <=0.31.22 Post mortem As part of implementing the Cube Cloud SQL runner functionality, we’ve added a new endpoint to the Cube Core so that we could add arbitrary queries directly to the queue, bypassing the modeling layer. The endpoint was added in this commit: https://github.com/cube-js/cube.js/commit/f1e25bb50323c0b99f3891d349467e7b637baeea It went through the code review; however, it slipped everyone’s attention that this endpoint completely bypasses any row-level security logic implemented in the modeling layer. Now anyone with a valid Cube JWT token could fetch any data, even if they were not allowed to do so by their security context. The issue was noticed by the Core team on Dec 12 and immediately reverted. The just-released 0.31.23 version of…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-6jqm-3c9g-pch7

  2. Revision 1 · created ·

    Published from osv record GHSA-6jqm-3c9g-pch7

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2022-23510

Advisory: @cubejs-backend/api-gateway row level security bypass
IDs: CVE-2022-23510, GHSA-6jqm-3c9g-pch7
Record: https://patchnext.com/advisories/cve-2022-23510 (revision 2, source checked 26 Oct 2026, 12:16 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.7)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: @cubejs-backend/api-gateway 0.31.24. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm @cubejs-backend/api-gateway: affected >= 0.31.23, <= 0.31.23; fixed in 0.31.24

## Suggested inspection (read-only)
- `npm ls @cubejs-backend/api-gateway --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on @cubejs-backend/api-gateway.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-6jqm-3c9g-pch7 (OSV record GHSA-6jqm-3c9g-pch7 lists affected ranges: npm @cubejs-backend/api-gateway >=0.31.23 <0.31.24 (fixed))
- Verified: https://github.com/advisories/GHSA-6jqm-3c9g-pch7 (GitHub-reviewed advisory GHSA-6jqm-3c9g-pch7 lists affected ranges: npm @cubejs-backend/api-gateway >=0.31.23 <=0.31.23)

Commands are suggestions: review each one before running it.

Loading voting…