GitOps Run allows for Kubernetes workload injection
CVE-2022-23508GHSA-wr3c-g326-486c
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/weaveworks/weave-gitops 0.12.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Go github.com/weaveworks/weave-gitops
- Affected
- <= 0.11.0
- Fixed in
- 0.12.0
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-wr3c-g326-486c lists affected ranges: Go github.com/weaveworks/weave-gitops >=0 <=0.11.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 8.8 · CVSS:3.1/AV:A/AC:L/PR:N/UI:R/S:C/C:H/I:H/A:H
- EPSS
- CVE-2022-23508: 0.33% estimated exploitation activity in the next 30 days; percentile 26.54 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact A vulnerability in GitOps run could allow a local user or process to alter a Kubernetes cluster's resources. GitOps run has a local S3 bucket which it uses for synchronising files that are later applied against a Kubernetes cluster. Its endpoint had no security controls to block unauthorised access, therefore allowing local users (and processes) on the same machine to see and alter the bucket content. By leveraging this vulnerability, an attacker could pick a workload of their choosing and inject it into the S3 bucket, which resulted in the successful deployment in the target cluster, without the need to provide any credentials to either the S3 bucket nor the target Kubernetes cluster. Patches This vulnerability has been fixed by commits 75268c4 and 966823b. Users should upgrade to Weave GitOps version = v0.12.0 released on 08/12/2022. Workarounds There is no workaround for this vulnerability. References Disclosed by Paulo Gomes, Senior Software Engineer, Weaveworks. For more…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-wr3c-g326-486c
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2022-23508 Advisory: GitOps Run allows for Kubernetes workload injection IDs: CVE-2022-23508, GHSA-wr3c-g326-486c Record: https://patchnext.com/advisories/cve-2022-23508 (revision 1, source checked 26 Oct 2026, 14:54 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.8) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: github.com/weaveworks/weave-gitops 0.12.0. A vendor fix does not mean a deployment is fixed. ## Affected components - Go github.com/weaveworks/weave-gitops: affected <= 0.11.0; fixed in 0.12.0 ## Suggested inspection (read-only) - Go github.com/weaveworks/weave-gitops: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on github.com/weaveworks/weave-gitops. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-wr3c-g326-486c (GitHub-reviewed advisory GHSA-wr3c-g326-486c lists affected ranges: Go github.com/weaveworks/weave-gitops >=0 <=0.11.0) Commands are suggestions: review each one before running it.
Loading voting…