Tendermint light client verification not taking into account chain ID
CVE-2022-23507GHSA-xqqc-c5gw-c5r5
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (tendermint-light-client-js 0.28.0; tendermint-light-client-verifier 0.28.0; tendermint-light-client 0.28.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
crates.io tendermint-light-client-js
- Affected
- <= 0.27.0
- Fixed in
- 0.28.0
crates.io tendermint-light-client-verifier
- Affected
- <= 0.27.0
- Fixed in
- 0.28.0
crates.io tendermint-light-client
- Affected
- <= 0.27.0
- Fixed in
- 0.28.0
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-xqqc-c5gw-c5r5 lists affected ranges: crates.io tendermint-light-client-verifier >=0 =0 =0 <=0.27.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 5.4 · CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:C/C:L/I:L/A:N
- EPSS
- CVE-2022-23507: 0.32% estimated exploitation activity in the next 30 days; percentile 24.60 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact Anyone using the tendermint-light-client and related packages to perform light client verification (e.g. IBC-rs, Hermes). At present, the light client does not check that the chain IDs of the trusted and untrusted headers match, resulting in a possible attack vector where someone who finds a header from an untrusted chain that satisfies all other verification conditions (e.g. enough overlapping validator signatures) could fool a light client. The attack vector is currently theoretical, and no proof-of-concept exists yet to exploit it on live networks. Patches Users of the light client-related crates can currently upgrade to v0.28.0. Workarounds None References - Light Client specification
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-xqqc-c5gw-c5r5
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2022-23507 Advisory: Tendermint light client verification not taking into account chain ID IDs: CVE-2022-23507, GHSA-xqqc-c5gw-c5r5 Record: https://patchnext.com/advisories/cve-2022-23507 (revision 1, source checked 26 Oct 2026, 15:33 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.4) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: tendermint-light-client-js 0.28.0; tendermint-light-client-verifier 0.28.0; tendermint-light-client 0.28.0. A vendor fix does not mean a deployment is fixed. ## Affected components - crates.io tendermint-light-client-js: affected <= 0.27.0; fixed in 0.28.0 - crates.io tendermint-light-client-verifier: affected <= 0.27.0; fixed in 0.28.0 - crates.io tendermint-light-client: affected <= 0.27.0; fixed in 0.28.0 ## Suggested inspection (read-only) - crates.io tendermint-light-client-js: check the installed version with your package manager. - crates.io tendermint-light-client-verifier: check the installed version with your package manager. - crates.io tendermint-light-client: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on tendermint-light-client-js, tendermint-light-client-verifier, tendermint-light-client. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-xqqc-c5gw-c5r5 (GitHub-reviewed advisory GHSA-xqqc-c5gw-c5r5 lists affected ranges: crates.io tendermint-light-client-verifier >=0 =0 =0 <=0.27.0) Commands are suggestions: review each one before running it.
Loading voting…