Authentication Bypass for passport-wsfed-saml2
CVE-2022-23505GHSA-ppjq-qxhx-m25f
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (passport-wsfed-saml2 4.6.3), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
- Affected
- < 4.6.3
- Fixed in
- 4.6.3
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-ppjq-qxhx-m25f lists affected ranges: npm passport-wsfed-saml2 >=0 <4.6.3 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-ppjq-qxhx-m25f lists affected ranges: npm passport-wsfed-saml2 >=0 <4.6.3
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 5.3 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N
- EPSS
- CVE-2022-23505: 0.80% estimated exploitation activity in the next 30 days; percentile 56.63 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Overview A remote attacker can bypass WSFed authentication on a website using passport-wsfed-saml2. A successful attack requires that the attacker is in possession of an arbitrary IDP signed WSFed assertion. Depending on the IDP used, fully unauthenticated attacks (e.g without access to a valid user) might also be feasible if generation of a signed message can be triggered. Am I affected? You are affected if you are using WSFed protocol with the passport-wsfed-saml2 library versions < 4.6.3. SAML2 protocol is not affected. How do I fix it? Upgrade the library to version 4.6.3. Will the fix impact my users? No, the fix will not impact your users.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-ppjq-qxhx-m25f
- Revision 1 · created ·
Published from osv record GHSA-ppjq-qxhx-m25f
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2022-23505 Advisory: Authentication Bypass for passport-wsfed-saml2 IDs: CVE-2022-23505, GHSA-ppjq-qxhx-m25f Record: https://patchnext.com/advisories/cve-2022-23505 (revision 2, source checked 26 Oct 2026, 12:17 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: passport-wsfed-saml2 4.6.3. A vendor fix does not mean a deployment is fixed. ## Affected components - npm passport-wsfed-saml2: affected < 4.6.3; fixed in 4.6.3 ## Suggested inspection (read-only) - `npm ls passport-wsfed-saml2 --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on passport-wsfed-saml2. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-ppjq-qxhx-m25f (OSV record GHSA-ppjq-qxhx-m25f lists affected ranges: npm passport-wsfed-saml2 >=0 <4.6.3 (fixed)) - Verified: https://github.com/advisories/GHSA-ppjq-qxhx-m25f (GitHub-reviewed advisory GHSA-ppjq-qxhx-m25f lists affected ranges: npm passport-wsfed-saml2 >=0 <4.6.3) Commands are suggestions: review each one before running it.
Loading voting…