Skip to content

← Actionable
Medium, CVSS 5.9

TYPO3 CMS vulnerable to Weak Authentication in Frontend Login

CVE-2022-23501GHSA-jfp7-79g7-89rf

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (typo3/cms-core 12.1.1, 11.5.20, 10.4.33, 9.5.38, 8.7.49; typo3/cms 12.1.1, 11.5.20, 10.4.33), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Packagist typo3/cms-core

    Affected
    < 8.7.49>= 9.0.0, < 9.5.38>= 10.0.0, < 10.4.33>= 11.0.0, < 11.5.20>= 12.0.0, < 12.1.1
    Fixed in
    9.5.38, 11.5.20, 10.4.33, 12.1.1, 8.7.49
  • Packagist typo3/cms

    Affected
    >= 10.0.0, < 10.4.33>= 11.0.0, < 11.5.20>= 12.0.0, < 12.1.1
    Fixed in
    11.5.20, 10.4.33, 12.1.1

Sources

  • GitHub Advisory Database and maintainer security advisories on GitHub

    GitHub-reviewed advisory GHSA-jfp7-79g7-89rf lists affected ranges: Packagist typo3/cms-core >=0 =9.0.0 =10.0.0 =11.0.0 =12.0.0 =10.0.0 =11.0.0 =12.0.0 <12.1.1

    VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
5.9 · CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:L/A:N
EPSS
  • CVE-2022-23501: 0.51% estimated exploitation activity in the next 30 days; percentile 43.62 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Problem Restricting frontend login to specific users, organized in different storage folders (partitions), can be bypassed. A potential attacker might use this ambiguity in usernames to get access to a different account - however, credentials must be known to the adversary. Solution Update to TYPO3 versions 8.7.49 ELTS, 9.5.38 ELTS, 10.4.33, 11.5.20, 12.1.1 that fix the problem described above. References TYPO3-CORE-SA-2022-013

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-jfp7-79g7-89rf

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2022-23501

Advisory: TYPO3 CMS vulnerable to Weak Authentication in Frontend Login
IDs: CVE-2022-23501, GHSA-jfp7-79g7-89rf
Record: https://patchnext.com/advisories/cve-2022-23501 (revision 1, source checked 26 Oct 2026, 14:00 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.9)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: typo3/cms-core 12.1.1, 11.5.20, 10.4.33, 9.5.38, 8.7.49; typo3/cms 12.1.1, 11.5.20, 10.4.33. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist typo3/cms-core: affected < 8.7.49; >= 9.0.0, < 9.5.38; >= 10.0.0, < 10.4.33; >= 11.0.0, < 11.5.20; >= 12.0.0, < 12.1.1; fixed in 9.5.38, 11.5.20, 10.4.33, 12.1.1, 8.7.49
- Packagist typo3/cms: affected >= 10.0.0, < 10.4.33; >= 11.0.0, < 11.5.20; >= 12.0.0, < 12.1.1; fixed in 11.5.20, 10.4.33, 12.1.1

## Suggested inspection (read-only)
- Packagist typo3/cms-core: check the installed version with your package manager.
- Packagist typo3/cms: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on typo3/cms-core, typo3/cms.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-jfp7-79g7-89rf (GitHub-reviewed advisory GHSA-jfp7-79g7-89rf lists affected ranges: Packagist typo3/cms-core >=0 =9.0.0 =10.0.0 =11.0.0 =12.0.0 =10.0.0 =11.0.0 =12.0.0 <12.1.1)

Commands are suggestions: review each one before running it.

Loading voting…