Skip to content

← Actionable
Medium, CVSS 5.9

TYPO3 CMS vulnerable to Denial of Service in Page Error Handling

CVE-2022-23500GHSA-8c28-5mp7-v24h

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (typo3/cms-core 11.5.20, 10.4.33, 9.5.38; typo3/cms 11.5.20, 10.4.33), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Packagist typo3/cms-core

    Affected
    >= 9.0.0, < 9.5.38>= 10.0.0, < 10.4.33>= 11.0.0, < 11.5.20
    Fixed in
    9.5.38, 11.5.20, 10.4.33
  • Packagist typo3/cms

    Affected
    >= 10.0.0, < 10.4.33>= 11.0.0, < 11.5.20
    Fixed in
    11.5.20, 10.4.33

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
5.9 · CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:H
EPSS
  • CVE-2022-23500: 0.73% estimated exploitation activity in the next 30 days; percentile 54.34 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Problem Requesting invalid or non-existing resources via HTTP triggers the page error handler, which again could retrieve content to be shown as an error message from another page. This leads to a scenario in which the application is calling itself recursively - amplifying the impact of the initial attack until the limits of the web server are exceeded. This vulnerability is very similar, but not identical, to the one described in TYPO3-CORE-SA-2021-005 (CVE-2021-21359). Solution Update to TYPO3 versions 9.5.38 ELTS, 10.4.33 or 11.5.20 that fix the problem described above. References TYPO3-CORE-SA-2022-012

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-8c28-5mp7-v24h

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2022-23500

Advisory: TYPO3 CMS vulnerable to Denial of Service in Page Error Handling
IDs: CVE-2022-23500, GHSA-8c28-5mp7-v24h
Record: https://patchnext.com/advisories/cve-2022-23500 (revision 1, source checked 26 Oct 2026, 14:00 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.9)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: typo3/cms-core 11.5.20, 10.4.33, 9.5.38; typo3/cms 11.5.20, 10.4.33. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist typo3/cms-core: affected >= 9.0.0, < 9.5.38; >= 10.0.0, < 10.4.33; >= 11.0.0, < 11.5.20; fixed in 9.5.38, 11.5.20, 10.4.33
- Packagist typo3/cms: affected >= 10.0.0, < 10.4.33; >= 11.0.0, < 11.5.20; fixed in 11.5.20, 10.4.33

## Suggested inspection (read-only)
- Packagist typo3/cms-core: check the installed version with your package manager.
- Packagist typo3/cms: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on typo3/cms-core, typo3/cms.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-8c28-5mp7-v24h (GitHub-reviewed advisory GHSA-8c28-5mp7-v24h lists affected ranges: Packagist typo3/cms-core >=9.0.0 =10.0.0 =11.0.0 =10.0.0 =11.0.0 <11.5.20)

Commands are suggestions: review each one before running it.

Loading voting…