Skip to content

← Actionable
Medium, CVSS 5.4amended

Cross-site scripting vulnerability in TinyMCE alerts

CVE-2022-23494GHSA-gg8r-xjwq-4w92

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (tinymce 6.3.1, 5.10.7; tinymce/tinymce 6.3.1, 5.10.7; tinymce 6.3.1, 5.10.7), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • NuGet tinymce

    Affected
    >= 6.0.0, < 6.3.1< 5.10.7
    Fixed in
    6.3.1, 5.10.7
  • Packagist tinymce/tinymce

    Affected
    >= 6.0.0, < 6.3.1< 5.10.7
    Fixed in
    6.3.1, 5.10.7
  • npm tinymce

    Affected
    >= 6.0.0, < 6.3.1< 5.10.7
    Fixed in
    6.3.1, 5.10.7

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
5.4 · CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N
EPSS
  • CVE-2022-23494: 1.01% estimated exploitation activity in the next 30 days; percentile 63.32 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact A cross-site scripting (XSS) vulnerability was discovered in the alert and confirm dialogs when these dialogs were provided with malicious HTML content. This can occur in plugins that use the alert or confirm dialogs, such as in the image plugin, which presents these dialogs when certain errors occur. The vulnerability allowed arbitrary JavaScript execution when an alert presented in the TinyMCE UI for the current user. Patches This vulnerability has been patched in TinyMCE 5.10.7 and TinyMCE 6.3.1 by ensuring HTML sanitization was still performed after unwrapping invalid elements. Fix To avoid this vulnerability: - Upgrade to TinyMCE 5.10.7 or higher for TinyMCE 5.x. - Upgrade to TinyMCE 6.3.1 or higher for TinyMCE 6.x. Workaround To reduce the impact of this vulnerability: - Ensure the the imagesuploadhandler returns a valid value as per the imagesuploadhandler documentation. References - https://www.tiny.cloud/docs/release-notes/release-notes5107/#securityfixes -…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-gg8r-xjwq-4w92

  2. Revision 1 · created ·

    Published from osv record GHSA-gg8r-xjwq-4w92

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2022-23494

Advisory: Cross-site scripting vulnerability in TinyMCE alerts
IDs: CVE-2022-23494, GHSA-gg8r-xjwq-4w92
Record: https://patchnext.com/advisories/cve-2022-23494 (revision 2, source checked 26 Oct 2026, 12:16 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.4)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: tinymce 6.3.1, 5.10.7; tinymce/tinymce 6.3.1, 5.10.7; tinymce 6.3.1, 5.10.7. A vendor fix does not mean a deployment is fixed.

## Affected components
- NuGet tinymce: affected >= 6.0.0, < 6.3.1; < 5.10.7; fixed in 6.3.1, 5.10.7
- Packagist tinymce/tinymce: affected >= 6.0.0, < 6.3.1; < 5.10.7; fixed in 6.3.1, 5.10.7
- npm tinymce: affected >= 6.0.0, < 6.3.1; < 5.10.7; fixed in 6.3.1, 5.10.7

## Suggested inspection (read-only)
- NuGet tinymce: check the installed version with your package manager.
- Packagist tinymce/tinymce: check the installed version with your package manager.
- `npm ls tinymce --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on tinymce, tinymce/tinymce.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-gg8r-xjwq-4w92 (OSV record GHSA-gg8r-xjwq-4w92 lists affected ranges: npm tinymce >=6.0.0 =0 =6.0.0 =0 =6.0.0 =0 <5.10.7 (fixed))
- Verified: https://github.com/advisories/GHSA-gg8r-xjwq-4w92 (GitHub-reviewed advisory GHSA-gg8r-xjwq-4w92 lists affected ranges: npm tinymce >=6.0.0 =0 =6.0.0 =0 =6.0.0 =0 <5.10.7)

Commands are suggestions: review each one before running it.

Loading voting…