Skip to content

← Actionable
High, CVSS 7.5

libp2p DoS vulnerability from lack of resource management

CVE-2022-23492GHSA-j7qp-mfxf-8xjw

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/libp2p/go-libp2p 0.18.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
EPSS
  • CVE-2022-23492: 1.05% estimated exploitation activity in the next 30 days; percentile 64.34 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact Versions older than v0.18.0 of go-libp2p are vulnerable to targeted resource exhaustion attacks. These attacks target libp2p’s connection, stream, peer, and memory management. An attacker can cause the allocation of large amounts of memory, ultimately leading to the process getting killed by the host’s operating system. While a connection manager tasked with keeping the number of connections within manageable limits has been part of go-libp2p, this component was designed to handle the regular churn of peers, not a targeted resource exhaustion attack. In the original version of the attack, the malicious node would continue opening new streams on a stream multiplexer that doesn’t provide sufficient back pressure (yamux or mplex). It is easy to defend against this one attack, but there are countless variations of this attack: Opening streams and causing a non-trivial memory allocation (e.g., for multistream or protobuf parsing) Creating a lot of sybil nodes and opening new…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-j7qp-mfxf-8xjw

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2022-23492

Advisory: libp2p DoS vulnerability from lack of resource management
IDs: CVE-2022-23492, GHSA-j7qp-mfxf-8xjw
Record: https://patchnext.com/advisories/cve-2022-23492 (revision 1, source checked 26 Oct 2026, 14:55 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: github.com/libp2p/go-libp2p 0.18.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- Go github.com/libp2p/go-libp2p: affected < 0.18.0; fixed in 0.18.0

## Suggested inspection (read-only)
- Go github.com/libp2p/go-libp2p: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on github.com/libp2p/go-libp2p.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-j7qp-mfxf-8xjw (GitHub-reviewed advisory GHSA-j7qp-mfxf-8xjw lists affected ranges: Go github.com/libp2p/go-libp2p >=0 <0.18.0)

Commands are suggestions: review each one before running it.

Loading voting…