Skip to content

← Actionable
Medium, CVSS 5.9amended

Certifi removing TrustCor root certificate

CVE-2022-23491GHSA-43fp-rhv2-5gv8

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (certifi 2022.12.7), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI certifi

    Affected
    >= 2017.11.5, < 2022.12.7
    Fixed in
    2022.12.7

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
5.9 · CVSS:4.0/AV:N/AC:L/AT:P/PR:H/UI:N/VC:N/VI:H/VA:N/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2022-23491: 0.53% estimated exploitation activity in the next 30 days; percentile 44.87 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Certifi 2022.12.07 removes root certificates from "TrustCor" from the root store. These are in the process of being removed from Mozilla's trust store. TrustCor's root certificates are being removed pursuant to an investigation prompted by media reporting that TrustCor's ownership also operated a business that produced spyware. Conclusions of Mozilla's investigation can be found here.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-43fp-rhv2-5gv8

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-43fp-rhv2-5gv8

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2022-23491

Advisory: Certifi removing TrustCor root certificate
IDs: CVE-2022-23491, GHSA-43fp-rhv2-5gv8
Record: https://patchnext.com/advisories/cve-2022-23491 (revision 3, source checked 26 Oct 2026, 13:30 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.9)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: certifi 2022.12.7. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI certifi: affected >= 2017.11.5, < 2022.12.7; fixed in 2022.12.7

## Suggested inspection (read-only)
- `python -m pip show certifi`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on certifi.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-43fp-rhv2-5gv8 (OSV record GHSA-43fp-rhv2-5gv8 lists affected ranges: PyPI certifi >=2017.11.05 <2022.12.07 (fixed))
- Verified: https://github.com/advisories/GHSA-43fp-rhv2-5gv8 (GitHub-reviewed advisory GHSA-43fp-rhv2-5gv8 lists affected ranges: PyPI certifi >=2017.11.5 <2022.12.7)

Commands are suggestions: review each one before running it.

Loading voting…