libp2p DoS vulnerability from lack of resource management
CVE-2022-23487GHSA-f44q-634c-jvwv
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (libp2p 0.38.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm libp2p
- Affected
- < 0.38.0
- Fixed in
- 0.38.0
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-f44q-634c-jvwv lists affected ranges: npm libp2p >=0 <0.38.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-f44q-634c-jvwv lists affected ranges: npm libp2p >=0 <0.38.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- EPSS
- CVE-2022-23487: 0.73% estimated exploitation activity in the next 30 days; percentile 54.46 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact Versions older than v0.38.0 of js-libp2p are vulnerable to targeted resource exhaustion attacks. These attacks target libp2p’s connection, stream, peer, and memory management. An attacker can cause the allocation of large amounts of memory, ultimately leading to the process getting killed by the host’s operating system. While a connection manager tasked with keeping the number of connections within manageable limits has been part of js-libp2p, this component was designed to handle the regular churn of peers, not a targeted resource exhaustion attack. Patches (What to do as a js-libp2p consumer:) Update your js-libp2p dependency to v0.38.0 or greater. Workarounds There are no workarounds, and so we recommend to upgrade your js-libp2p version. Some range of attacks can be mitigated using OS tools (like manually blocking malicious peers using iptables or ufw ) or making use of a load balancer in front of libp2p nodes. You can also use the allow deny list in js-libp2p to deny…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-f44q-634c-jvwv
- Revision 1 · created ·
Published from osv record GHSA-f44q-634c-jvwv
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2022-23487 Advisory: libp2p DoS vulnerability from lack of resource management IDs: CVE-2022-23487, GHSA-f44q-634c-jvwv Record: https://patchnext.com/advisories/cve-2022-23487 (revision 2, source checked 26 Oct 2026, 12:22 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: libp2p 0.38.0. A vendor fix does not mean a deployment is fixed. ## Affected components - npm libp2p: affected < 0.38.0; fixed in 0.38.0 ## Suggested inspection (read-only) - `npm ls libp2p --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on libp2p. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-f44q-634c-jvwv (OSV record GHSA-f44q-634c-jvwv lists affected ranges: npm libp2p >=0 <0.38.0 (fixed)) - Verified: https://github.com/advisories/GHSA-f44q-634c-jvwv (GitHub-reviewed advisory GHSA-f44q-634c-jvwv lists affected ranges: npm libp2p >=0 <0.38.0) Commands are suggestions: review each one before running it.
Loading voting…