Skip to content

← Actionable
Medium, CVSS 6.4amended

Sentry vulnerable to invite code reuse via cookie manipulation

CVE-2022-23485GHSA-jv85-mqxj-3f9j

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (sentry 22.11.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI sentry

    Affected
    >= 20.6.0, < 22.11.0
    Fixed in
    22.11.0

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
6.4 · CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:H/I:L/A:L
EPSS
  • CVE-2022-23485: 0.45% estimated exploitation activity in the next 30 days; percentile 39.26 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

With a known valid invite link (i.e. not already accepted or expired) an unauthenticated attacker can manipulate the cookie to allow the same invite link to be reused on multiple accounts when joining an organization. Impact An attacker with a valid invite link can create multiple users and join the organization from which the invite link was generated. Patches This issue was patched in version 22.11.0. Workarounds Sentry SaaS customers do not need to take action. Self-hosted Sentry installs can disable the invite functionality until they are ready to deploy the patched version by editing their sentry.conf.py file (usually located at ~/.sentry/). 1. Add the following line into sentry.conf.py: 2. Restart the Sentry web service. For more information If you have any questions or comments about this advisory: Visit our FAQs on this CVE Open an issue in getsentry/sentry Email us at security[@]sentry.io

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-jv85-mqxj-3f9j

  2. Revision 1 · created ·

    Published from osv record GHSA-jv85-mqxj-3f9j

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2022-23485

Advisory: Sentry vulnerable to invite code reuse via cookie manipulation
IDs: CVE-2022-23485, GHSA-jv85-mqxj-3f9j
Record: https://patchnext.com/advisories/cve-2022-23485 (revision 2, source checked 26 Oct 2026, 13:22 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.4)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: sentry 22.11.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI sentry: affected >= 20.6.0, < 22.11.0; fixed in 22.11.0

## Suggested inspection (read-only)
- `python -m pip show sentry`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on sentry.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-jv85-mqxj-3f9j (OSV record GHSA-jv85-mqxj-3f9j lists affected ranges: PyPI sentry >=20.6.0 <22.11.0 (fixed))
- Verified: https://github.com/advisories/GHSA-jv85-mqxj-3f9j (GitHub-reviewed advisory GHSA-jv85-mqxj-3f9j lists affected ranges: PyPI sentry >=20.6.0 <22.11.0)

Commands are suggestions: review each one before running it.

Loading voting…