Passeo uses insecure random number generator
CVE-2022-23472GHSA-mhhf-vgwh-fw9h
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (passeo 1.0.5), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI passeo
- Affected
- < 1.0.5
- Fixed in
- 1.0.5
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-mhhf-vgwh-fw9h lists affected ranges: PyPI passeo >=0 <1.0.5 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-mhhf-vgwh-fw9h lists affected ranges: PyPI passeo >=0 <1.0.5
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 8.2 · CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N · score source
- EPSS
- CVE-2022-23472: 0.86% estimated exploitation activity in the next 30 days; percentile 58.53 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact Everyone below v1.0.5 is impacted by this flaw, of confidentiality being at risk due to the password(s) being easily able to be guessed with Passeo's use of the random library. It is recommended to change any passwords made with Passeo before v1.0.5 and upgrade to v1.0.5, and v1.0.5 patches this with the secrets library. Workarounds No current workaround available than updating to v1.0.5.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-mhhf-vgwh-fw9h
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-mhhf-vgwh-fw9h
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2022-23472 Advisory: Passeo uses insecure random number generator IDs: CVE-2022-23472, GHSA-mhhf-vgwh-fw9h Record: https://patchnext.com/advisories/cve-2022-23472 (revision 3, source checked 26 Oct 2026, 13:21 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.2) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: passeo 1.0.5. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI passeo: affected < 1.0.5; fixed in 1.0.5 ## Suggested inspection (read-only) - `python -m pip show passeo`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on passeo. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-mhhf-vgwh-fw9h (OSV record GHSA-mhhf-vgwh-fw9h lists affected ranges: PyPI passeo >=0 <1.0.5 (fixed)) - Verified: https://github.com/advisories/GHSA-mhhf-vgwh-fw9h (GitHub-reviewed advisory GHSA-mhhf-vgwh-fw9h lists affected ranges: PyPI passeo >=0 <1.0.5) Commands are suggestions: review each one before running it.
Loading voting…