Skip to content

← Actionable
Medium, CVSS 5.7

containerd CRI stream server vulnerable to host memory exhaustion via terminal

CVE-2022-23471GHSA-2qjp-425j-52j9

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/containerd/containerd 1.6.12, 1.5.16), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
5.7 · CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:N/I:N/A:H
EPSS
  • CVE-2022-23471: 1.11% estimated exploitation activity in the next 30 days; percentile 65.94 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact A bug was found in containerd's CRI implementation where a user can exhaust memory on the host. In the CRI stream server, a goroutine is launched to handle terminal resize events if a TTY is requested. If the user's process fails to launch due to, for example, a faulty command, the goroutine will be stuck waiting to send without a receiver, resulting in a memory leak. Kubernetes and crictl can both be configured to use containerd's CRI implementation and the stream server is used for handling container IO. Patches This bug has been fixed in containerd 1.6.12 and 1.5.16. Users should update to these versions to resolve the issue. Workarounds Ensure that only trusted images and commands are used and that only trusted users have permissions to execute commands in running containers. For more information If you have any questions or comments about this advisory: Open an issue in containerd Email us at security@containerd.io To report a security issue in containerd: Report a new…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-2qjp-425j-52j9

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2022-23471

Advisory: containerd CRI stream server vulnerable to host memory exhaustion via terminal
IDs: CVE-2022-23471, GHSA-2qjp-425j-52j9
Record: https://patchnext.com/advisories/cve-2022-23471 (revision 1, source checked 26 Oct 2026, 15:03 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.7)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: github.com/containerd/containerd 1.6.12, 1.5.16. A vendor fix does not mean a deployment is fixed.

## Affected components
- Go github.com/containerd/containerd: affected < 1.5.16; >= 1.6.0, < 1.6.12; fixed in 1.5.16, 1.6.12

## Suggested inspection (read-only)
- Go github.com/containerd/containerd: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on github.com/containerd/containerd.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-2qjp-425j-52j9 (GitHub-reviewed advisory GHSA-2qjp-425j-52j9 lists affected ranges: Go github.com/containerd/containerd >=0 =1.6.0 <1.6.12)

Commands are suggestions: review each one before running it.

Loading voting…