Skip to content

← Actionable
Medium, CVSS 6.1amended

Toast UI Grid vulnerable to Cross-site Scripting

CVE-2022-23458GHSA-9rwj-9j2h-fhvm

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (tui-grid 4.21.3), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm tui-grid

    Affected
    < 4.21.3
    Fixed in
    4.21.3

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
6.1 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
EPSS
  • CVE-2022-23458: 0.67% estimated exploitation activity in the next 30 days; percentile 51.91 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Toast UI Grid is a component to display and edit data. Versions prior to 4.21.3 are vulnerable to cross-site scripting attacks when pasting specially crafted content into editable cells. This issue was fixed in version 4.21.3. There are no known workarounds.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-9rwj-9j2h-fhvm

  2. Revision 1 · created ·

    Published from osv record GHSA-9rwj-9j2h-fhvm

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2022-23458

Advisory: Toast UI Grid vulnerable to Cross-site Scripting
IDs: CVE-2022-23458, GHSA-9rwj-9j2h-fhvm
Record: https://patchnext.com/advisories/cve-2022-23458 (revision 2, source checked 26 Oct 2026, 12:17 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: tui-grid 4.21.3. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm tui-grid: affected < 4.21.3; fixed in 4.21.3

## Suggested inspection (read-only)
- `npm ls tui-grid --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on tui-grid.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-9rwj-9j2h-fhvm (OSV record GHSA-9rwj-9j2h-fhvm lists affected ranges: npm tui-grid >=0 <4.21.3 (fixed))
- Verified: https://github.com/advisories/GHSA-9rwj-9j2h-fhvm (GitHub-reviewed advisory GHSA-9rwj-9j2h-fhvm lists affected ranges: npm tui-grid >=0 <4.21.3)

Commands are suggestions: review each one before running it.

Loading voting…