android-gif-drawable vulerable to denial of service due to unrestricted comment length
CVE-2022-23435GHSA-3mm4-w7v6-4rhv
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (pl.droidsonroids.gif:android-gif-drawable 1.2.24), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven pl.droidsonroids.gif:android-gif-drawable
- Affected
- < 1.2.24
- Fixed in
- 1.2.24
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-3mm4-w7v6-4rhv lists affected ranges: Maven pl.droidsonroids.gif:android-gif-drawable >=0 <1.2.24
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- EPSS
- CVE-2022-23435: 1.19% estimated exploitation activity in the next 30 days; percentile 68.02 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
decoding.c in android-gif-drawable before 1.2.24 does not limit the maximum length of a comment, leading to denial of service.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-3mm4-w7v6-4rhv
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2022-23435 Advisory: android-gif-drawable vulerable to denial of service due to unrestricted comment length IDs: CVE-2022-23435, GHSA-3mm4-w7v6-4rhv Record: https://patchnext.com/advisories/cve-2022-23435 (revision 1, source checked 26 Oct 2026, 16:34 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: pl.droidsonroids.gif:android-gif-drawable 1.2.24. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven pl.droidsonroids.gif:android-gif-drawable: affected < 1.2.24; fixed in 1.2.24 ## Suggested inspection (read-only) - Maven pl.droidsonroids.gif:android-gif-drawable: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on pl.droidsonroids.gif:android-gif-drawable. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-3mm4-w7v6-4rhv (GitHub-reviewed advisory GHSA-3mm4-w7v6-4rhv lists affected ranges: Maven pl.droidsonroids.gif:android-gif-drawable >=0 <1.2.24) Commands are suggestions: review each one before running it.
Loading voting…