Skip to content

← Actionable
High, CVSS 7.0

Race condition in Apache Tomcat

CVE-2022-23181GHSA-9f3j-pm6f-9fm5

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.apache.tomcat:tomcat 10.0.16, 9.0.58, 8.5.75), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.0 · CVSS:3.1/AV:L/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:H
EPSS
  • CVE-2022-23181: 0.69% estimated exploitation activity in the next 30 days; percentile 52.92 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

The fix for bug CVE-2020-9484 introduced a time of check time of use vulnerability into Apache Tomcat 10.1.0-M1 to 10.1.0-M8, 10.0.0-M5 to 10.0.14, 9.0.35 to 9.0.56 and 8.5.55 to 8.5.73 that allowed a local attacker to perform actions with the privileges of the user that the Tomcat process is using. This issue is only exploitable when Tomcat is configured to persist sessions using the FileStore.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-9f3j-pm6f-9fm5

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2022-23181

Advisory: Race condition in Apache Tomcat
IDs: CVE-2022-23181, GHSA-9f3j-pm6f-9fm5
Record: https://patchnext.com/advisories/cve-2022-23181 (revision 1, source checked 26 Oct 2026, 16:02 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.0)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: org.apache.tomcat:tomcat 10.0.16, 9.0.58, 8.5.75. A vendor fix does not mean a deployment is fixed.

## Affected components
- Maven org.apache.tomcat:tomcat: affected >= 10.0.0, < 10.0.16; >= 9.0.0, < 9.0.58; < 8.5.75; fixed in 10.0.16, 9.0.58, 8.5.75

## Suggested inspection (read-only)
- Maven org.apache.tomcat:tomcat: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on org.apache.tomcat:tomcat.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-9f3j-pm6f-9fm5 (GitHub-reviewed advisory GHSA-9f3j-pm6f-9fm5 lists affected ranges: Maven org.apache.tomcat:tomcat >=10.0.0 =9.0.0 =0 <8.5.75)

Commands are suggestions: review each one before running it.

Loading voting…