lxml NULL Pointer Dereference allows attackers to cause a denial of service
CVE-2022-2309GHSA-wrxv-2j5q-m38w
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (lxml 4.9.1), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI lxml
- Affected
- < 4.9.1
- Fixed in
- 4.9.1
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-wrxv-2j5q-m38w lists affected ranges: PyPI lxml >=0 <4.9.1 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-wrxv-2j5q-m38w lists affected ranges: PyPI lxml >=0 <4.9.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 6.9 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N · score source
- EPSS
- CVE-2022-2309: 2.45% estimated exploitation activity in the next 30 days; percentile 84.39 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
NULL Pointer Dereference allows attackers to cause a denial of service (or application crash). This only applies when lxml is used together with libxml2 2.9.10 through 2.9.14. libxml2 2.9.9 and earlier are not affected. It allows triggering crashes through forged input data, given a vulnerable code sequence in the application. The vulnerability is caused by the iterwalk function (also used by the canonicalize function). Such code shouldn't be in wide-spread use, given that parsing + iterwalk would usually be replaced with the more efficient iterparse function. However, an XML converter that serialises to C14N would also be vulnerable, for example, and there are legitimate use cases for this code sequence. If untrusted input is received (also remotely) and processed via iterwalk function, a crash can be triggered.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-wrxv-2j5q-m38w
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-wrxv-2j5q-m38w
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2022-2309 Advisory: lxml NULL Pointer Dereference allows attackers to cause a denial of service IDs: CVE-2022-2309, GHSA-wrxv-2j5q-m38w Record: https://patchnext.com/advisories/cve-2022-2309 (revision 3, source checked 26 Oct 2026, 13:35 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.9) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: lxml 4.9.1. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI lxml: affected < 4.9.1; fixed in 4.9.1 ## Suggested inspection (read-only) - `python -m pip show lxml`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on lxml. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-wrxv-2j5q-m38w (OSV record GHSA-wrxv-2j5q-m38w lists affected ranges: PyPI lxml >=0 <4.9.1 (fixed)) - Verified: https://github.com/advisories/GHSA-wrxv-2j5q-m38w (GitHub-reviewed advisory GHSA-wrxv-2j5q-m38w lists affected ranges: PyPI lxml >=0 <4.9.1) Commands are suggestions: review each one before running it.
Loading voting…