Skip to content

← Actionable
Medium, CVSS 5.0amended

Server-Side Request Forgery in Directus

CVE-2022-23080GHSA-5h75-pvq4-82c9

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (directus 9.7.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm directus

    Affected
    >= 9.0.0-beta.2, < 9.7.0
    Fixed in
    9.7.0

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
5.0 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:N/A:N
EPSS
  • CVE-2022-23080: 0.83% estimated exploitation activity in the next 30 days; percentile 57.47 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Directus versions v9.0.0-beta.2 through 9.6.0 are vulnerable to server-side request forgery (SSRF) in the media upload functionality, which allows a low privileged user to perform internal network port scans.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-5h75-pvq4-82c9

  2. Revision 1 · created ·

    Published from osv record GHSA-5h75-pvq4-82c9

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2022-23080

Advisory: Server-Side Request Forgery in Directus
IDs: CVE-2022-23080, GHSA-5h75-pvq4-82c9
Record: https://patchnext.com/advisories/cve-2022-23080 (revision 2, source checked 26 Oct 2026, 12:16 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.0)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: directus 9.7.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm directus: affected >= 9.0.0-beta.2, < 9.7.0; fixed in 9.7.0

## Suggested inspection (read-only)
- `npm ls directus --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on directus.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-5h75-pvq4-82c9 (OSV record GHSA-5h75-pvq4-82c9 lists affected ranges: npm directus >=9.0.0-beta.2 <9.7.0 (fixed))
- Verified: https://github.com/advisories/GHSA-5h75-pvq4-82c9 (GitHub-reviewed advisory GHSA-5h75-pvq4-82c9 lists affected ranges: npm directus >=9.0.0-beta.2 <9.7.0)

Commands are suggestions: review each one before running it.

Loading voting…