Snyk plugins vulnerable to Command Injection
CVE-2022-22984GHSA-4x6g-3cmx-w76r
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (@snyk/snyk-cocoapods-plugin 2.5.3; snyk-mvn-plugin 2.31.3; snyk-sbt-plugin 2.16.2; snyk-docker-plugin 5.6.5; snyk-gradle-plugin 3.24.5; 3 more packages under Affected packages), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm @snyk/snyk-cocoapods-plugin
- Affected
- < 2.5.3
- Fixed in
- 2.5.3
npm snyk-mvn-plugin
- Affected
- < 2.31.3
- Fixed in
- 2.31.3
npm snyk-sbt-plugin
- Affected
- < 2.16.2
- Fixed in
- 2.16.2
- Affected
- < 5.6.5
- Fixed in
- 5.6.5
- Affected
- < 3.24.5
- Fixed in
- 3.24.5
npm snyk
- Affected
- < 1.1064.0
- Fixed in
- 1.1064.0
- Affected
- < 1.1.6
- Fixed in
- 1.1.6
- Affected
- < 1.24.2
- Fixed in
- 1.24.2
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-4x6g-3cmx-w76r lists affected ranges: npm snyk >=0 =0 =0 =0 =0 =0 =0 =0 <2.5.3 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-4x6g-3cmx-w76r lists affected ranges: npm snyk >=0 =0 =0 =0 =0 =0 =0 =0 <2.5.3
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 6.3 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:L
- EPSS
- CVE-2022-22984: 3.12% estimated exploitation activity in the next 30 days; percentile 87.83 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
The package snyk before 1.1064.0; the package snyk-mvn-plugin before 2.31.3; the package snyk-gradle-plugin before 3.24.5; the package @snyk/snyk-cocoapods-plugin before 2.5.3; the package snyk-sbt-plugin before 2.16.2; the package snyk-python-plugin before 1.24.2; the package snyk-docker-plugin before 5.6.5; the package @snyk/snyk-hex-plugin before 1.1.6 are vulnerable to Command Injection due to an incomplete fix for CVE-2022-40764. A successful exploit allows attackers to run arbitrary commands on the host system where the Snyk CLI is installed by passing in crafted command line flags. In order to exploit this vulnerability, a user would have to execute the snyk test command on untrusted files. In most cases, an attacker positioned to control the command line arguments to the Snyk CLI would already be positioned to execute arbitrary commands. However, this could be abused in specific scenarios, such as continuous integration pipelines, where developers can control the arguments…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-4x6g-3cmx-w76r
- Revision 1 · created ·
Published from osv record GHSA-4x6g-3cmx-w76r
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2022-22984 Advisory: Snyk plugins vulnerable to Command Injection IDs: CVE-2022-22984, GHSA-4x6g-3cmx-w76r Record: https://patchnext.com/advisories/cve-2022-22984 (revision 2, source checked 26 Oct 2026, 12:24 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: @snyk/snyk-cocoapods-plugin 2.5.3; snyk-mvn-plugin 2.31.3; snyk-sbt-plugin 2.16.2; snyk-docker-plugin 5.6.5; snyk-gradle-plugin 3.24.5; snyk 1.1064.0; @snyk/snyk-hex-plugin 1.1.6; snyk-python-plugin 1.24.2. A vendor fix does not mean a deployment is fixed. ## Affected components - npm @snyk/snyk-cocoapods-plugin: affected < 2.5.3; fixed in 2.5.3 - npm snyk-mvn-plugin: affected < 2.31.3; fixed in 2.31.3 - npm snyk-sbt-plugin: affected < 2.16.2; fixed in 2.16.2 - npm snyk-docker-plugin: affected < 5.6.5; fixed in 5.6.5 - npm snyk-gradle-plugin: affected < 3.24.5; fixed in 3.24.5 - npm snyk: affected < 1.1064.0; fixed in 1.1064.0 - npm @snyk/snyk-hex-plugin: affected < 1.1.6; fixed in 1.1.6 - npm snyk-python-plugin: affected < 1.24.2; fixed in 1.24.2 ## Suggested inspection (read-only) - `npm ls @snyk/snyk-cocoapods-plugin --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. - `npm ls snyk-mvn-plugin --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. - `npm ls snyk-sbt-plugin --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. - `npm ls snyk-docker-plugin --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. - `npm ls snyk-gradle-plugin --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. - `npm ls snyk --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. - `npm ls @snyk/snyk-hex-plugin --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. - `npm ls snyk-python-plugin --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on @snyk/snyk-cocoapods-plugin, snyk-mvn-plugin, snyk-sbt-plugin, snyk-docker-plugin, snyk-gradle-plugin, snyk, @snyk/snyk-hex-plugin, snyk-python-plugin. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-4x6g-3cmx-w76r (OSV record GHSA-4x6g-3cmx-w76r lists affected ranges: npm snyk >=0 =0 =0 =0 =0 =0 =0 =0 <2.5.3 (fixed)) - Verified: https://github.com/advisories/GHSA-4x6g-3cmx-w76r (GitHub-reviewed advisory GHSA-4x6g-3cmx-w76r lists affected ranges: npm snyk >=0 =0 =0 =0 =0 =0 =0 =0 <2.5.3) Commands are suggestions: review each one before running it.
Loading voting…