SpEL Injection in Spring Data MongoDB
CVE-2022-22980GHSA-w24x-87mr-4r23
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.springframework.data:spring-data-mongodb 3.4.1, 3.3.5), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven org.springframework.data:spring-data-mongodb
- Affected
- >= 3.4.0, <= 3.4.0< 3.3.5
- Fixed in
- 3.4.1, 3.3.5
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-w24x-87mr-4r23 lists affected ranges: Maven org.springframework.data:spring-data-mongodb >=3.4.0 =0 <3.3.5
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 9.0 · CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:C/C:H/I:H/A:H
- EPSS
- CVE-2022-22980: 17.84% estimated exploitation activity in the next 30 days; percentile 97.18 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
A Spring Data MongoDB application is vulnerable to SpEL Injection when using @Query or @Aggregation-annotated query methods with SpEL expressions that contain query parameter placeholders for value binding if the input is not sanitized.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-w24x-87mr-4r23
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2022-22980 Advisory: SpEL Injection in Spring Data MongoDB IDs: CVE-2022-22980, GHSA-w24x-87mr-4r23 Record: https://patchnext.com/advisories/cve-2022-22980 (revision 1, source checked 26 Oct 2026, 16:01 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 9.0) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: org.springframework.data:spring-data-mongodb 3.4.1, 3.3.5. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven org.springframework.data:spring-data-mongodb: affected >= 3.4.0, <= 3.4.0; < 3.3.5; fixed in 3.4.1, 3.3.5 ## Suggested inspection (read-only) - Maven org.springframework.data:spring-data-mongodb: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on org.springframework.data:spring-data-mongodb. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-w24x-87mr-4r23 (GitHub-reviewed advisory GHSA-w24x-87mr-4r23 lists affected ranges: Maven org.springframework.data:spring-data-mongodb >=3.4.0 =0 <3.3.5) Commands are suggestions: review each one before running it.
Loading voting…