Skip to content

← Actionable
Medium, CVSS 6.5

Denial of service in Spring Security OAuth2

CVE-2022-22969GHSA-c2cp-3xj9-97w9

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.springframework.security.oauth:spring-security-oauth2 2.5.2.RELEASE, 2.4.2.RELEASE), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

  • GitHub Advisory Database and maintainer security advisories on GitHub

    GitHub-reviewed advisory GHSA-c2cp-3xj9-97w9 lists affected ranges: Maven org.springframework.security.oauth:spring-security-oauth2 >=2.5.0.RELEASE =2.4.0.RELEASE <2.4.2.RELEASE

    VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
6.5 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H
EPSS
  • CVE-2022-22969: 1.25% estimated exploitation activity in the next 30 days; percentile 69.50 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Spring Security OAuth versions 2.5.x prior to 2.5.2 and older unsupported versions are susceptible to a Denial-of-Service (DoS) attack via the initiation of the Authorization Request in an OAuth 2.0 Client application. A malicious user or attacker can send multiple requests initiating the Authorization Request for the Authorization Code Grant, which has the potential of exhausting system resources using a single session. This vulnerability exposes OAuth 2.0 Client applications only.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-c2cp-3xj9-97w9

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2022-22969

Advisory: Denial of service in Spring Security OAuth2
IDs: CVE-2022-22969, GHSA-c2cp-3xj9-97w9
Record: https://patchnext.com/advisories/cve-2022-22969 (revision 1, source checked 26 Oct 2026, 16:30 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: org.springframework.security.oauth:spring-security-oauth2 2.5.2.RELEASE, 2.4.2.RELEASE. A vendor fix does not mean a deployment is fixed.

## Affected components
- Maven org.springframework.security.oauth:spring-security-oauth2: affected >= 2.5.0.RELEASE, < 2.5.2.RELEASE; >= 2.4.0.RELEASE, < 2.4.2.RELEASE; fixed in 2.4.2.RELEASE, 2.5.2.RELEASE

## Suggested inspection (read-only)
- Maven org.springframework.security.oauth:spring-security-oauth2: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on org.springframework.security.oauth:spring-security-oauth2.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-c2cp-3xj9-97w9 (GitHub-reviewed advisory GHSA-c2cp-3xj9-97w9 lists affected ranges: Maven org.springframework.security.oauth:spring-security-oauth2 >=2.5.0.RELEASE =2.4.0.RELEASE <2.4.2.RELEASE)

Commands are suggestions: review each one before running it.

Loading voting…