Incorrect header handling in mod-wsgi
CVE-2022-2255GHSA-7527-8855-9cf8
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (mod-wsgi 4.9.3), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI mod-wsgi
- Affected
- < 4.9.3
- Fixed in
- 4.9.3
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-7527-8855-9cf8 lists affected ranges: PyPI mod-wsgi >=0 <4.9.3 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-7527-8855-9cf8 lists affected ranges: PyPI mod-wsgi >=0 <4.9.3
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 8.7 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:H/VA:N/SC:N/SI:N/SA:N · score source
- EPSS
- CVE-2022-2255: 0.94% estimated exploitation activity in the next 30 days; percentile 60.97 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
A vulnerability was found in modwsgi. The X-Client-IP header is not removed from a request from an untrusted proxy, allowing an attacker to pass the X-Client-IP header to the target WSGI application because the condition to remove it is missing.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-7527-8855-9cf8
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-7527-8855-9cf8
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2022-2255 Advisory: Incorrect header handling in mod-wsgi IDs: CVE-2022-2255, GHSA-7527-8855-9cf8 Record: https://patchnext.com/advisories/cve-2022-2255 (revision 3, source checked 26 Oct 2026, 13:18 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.7) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: mod-wsgi 4.9.3. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI mod-wsgi: affected < 4.9.3; fixed in 4.9.3 ## Suggested inspection (read-only) - `python -m pip show mod-wsgi`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on mod-wsgi. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-7527-8855-9cf8 (OSV record GHSA-7527-8855-9cf8 lists affected ranges: PyPI mod-wsgi >=0 <4.9.3 (fixed)) - Verified: https://github.com/advisories/GHSA-7527-8855-9cf8 (GitHub-reviewed advisory GHSA-7527-8855-9cf8 lists affected ranges: PyPI mod-wsgi >=0 <4.9.3) Commands are suggestions: review each one before running it.
Loading voting…