Prototype Pollution in convict
CVE-2022-22143GHSA-x2w5-725j-gf2g
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (convict 6.2.3), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm convict
- Affected
- < 6.2.3
- Fixed in
- 6.2.3
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-x2w5-725j-gf2g lists affected ranges: npm convict >=0 <6.2.3 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-x2w5-725j-gf2g lists affected ranges: npm convict >=0 <6.2.3
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 8.4 · CVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- EPSS
- CVE-2022-22143: 2.18% estimated exploitation activity in the next 30 days; percentile 82.37 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact An attacker can inject attributes that are used in other components An attacker can override existing attributes with ones that have incompatible type, which may lead to a crash. The main use case of Convict is for handling server-side configurations written by the admins owning the servers, and not random users. So it's unlikely that an admin would deliberately sabotage their own server. Still a situation can happen where an admin not knowledgeable about JavaScript could be tricked by an attacker into writing the malicious JavaScript code into some config files. Patches The problem is patched in convict@6.2.3. Users should upgrade to convict@6.2.3. Workarounds No way for users to fix or remediate the vulnerability without upgrading References https://www.huntr.dev/bounties/1-npm-convict/ #384 3b86be087d8f14681a9c889d45da7fe3ad9cd880 1ea0ab19c5208f66509e1c43b0d0f21c1fd29b75 For more information If you have any questions or comments about this advisory: add your question as a…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-x2w5-725j-gf2g
- Revision 1 · created ·
Published from osv record GHSA-x2w5-725j-gf2g
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2022-22143 Advisory: Prototype Pollution in convict IDs: CVE-2022-22143, GHSA-x2w5-725j-gf2g Record: https://patchnext.com/advisories/cve-2022-22143 (revision 2, source checked 26 Oct 2026, 12:16 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.4) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: convict 6.2.3. A vendor fix does not mean a deployment is fixed. ## Affected components - npm convict: affected < 6.2.3; fixed in 6.2.3 ## Suggested inspection (read-only) - `npm ls convict --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on convict. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-x2w5-725j-gf2g (OSV record GHSA-x2w5-725j-gf2g lists affected ranges: npm convict >=0 <6.2.3 (fixed)) - Verified: https://github.com/advisories/GHSA-x2w5-725j-gf2g (GitHub-reviewed advisory GHSA-x2w5-725j-gf2g lists affected ranges: npm convict >=0 <6.2.3) Commands are suggestions: review each one before running it.
Loading voting…