Skip to content

← Actionable
High, CVSS 7.5amended

Allocation of Resources Without Limits or Throttling in nvflare

CVE-2022-21822GHSA-jx8f-cpx7-fv47

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (nvflare 2.0.16), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI nvflare

    Affected
    < 2.0.16
    Fixed in
    2.0.16

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
EPSS
  • CVE-2022-21822: 1.07% estimated exploitation activity in the next 30 days; percentile 64.82 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact NVIDIA FLARE contains a vulnerability in Admin Interface, where an un-authorized attacker can cause Allocation of Resources Without Limits or Throttling, which may lead to cause system unavailable All versions before 2.0.16 are affected. Patches The patch will be included in nvflare==2.0.16. Workarounds The changes in commits https://github.com/NVIDIA/NVFlare/commit/93588b3a0dff9bd4568983071b74d8b420de3a6e and https://github.com/NVIDIA/NVFlare/commit/93588b3a0dff9bd4568983071b74d8b420de3a6e can be applied to any version of the NVIDIA FLARE without any adverse effect. Additional information Issue Found on: 2022.3.3 Issue Found by: Oliver Sellwood (@Nintorac)

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-jx8f-cpx7-fv47

  2. Revision 1 · created ·

    Published from osv record GHSA-jx8f-cpx7-fv47

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2022-21822

Advisory: Allocation of Resources Without Limits or Throttling in nvflare
IDs: CVE-2022-21822, GHSA-jx8f-cpx7-fv47
Record: https://patchnext.com/advisories/cve-2022-21822 (revision 2, source checked 26 Oct 2026, 13:08 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: nvflare 2.0.16. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI nvflare: affected < 2.0.16; fixed in 2.0.16

## Suggested inspection (read-only)
- `python -m pip show nvflare`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on nvflare.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-jx8f-cpx7-fv47 (OSV record GHSA-jx8f-cpx7-fv47 lists affected ranges: PyPI nvflare >=0 <2.0.16 (fixed))
- Verified: https://github.com/advisories/GHSA-jx8f-cpx7-fv47 (GitHub-reviewed advisory GHSA-jx8f-cpx7-fv47 lists affected ranges: PyPI nvflare >=0 <2.0.16)

Commands are suggestions: review each one before running it.

Loading voting…