Skip to content

← Actionable
Medium, CVSS 5.9amended

Denial of Service Vulnerability in next.js

CVE-2022-21721GHSA-wr66-vrwm-5g5x

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (next 12.0.9), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm next

    Affected
    >= 12.0.0, < 12.0.9
    Fixed in
    12.0.9

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
5.9 · CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:H
EPSS
  • CVE-2022-21721: 2.15% estimated exploitation activity in the next 30 days; percentile 82.18 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact Vulnerable code could allow a bad actor to trigger a denial of service attack for anyone running a Next.js app at version = 12.0.0, and using i18n functionality. - Affected: All of the following must be true to be affected by this CVE - Next.js versions above v12.0.0 - Using next start or a custom server - Using the built-in i18n support - Not affected: - Deployments on Vercel (vercel.com) are not affected along with similar environments where invalid requests are filtered before reaching Next.js. Patches A patch has been released, next@12.0.9, that mitigates this issue. We recommend all affected users upgrade as soon as possible. Workarounds We recommend upgrading whether you can reproduce or not although you can ensure /${locale}/next/ is blocked from reaching the Next.js instance until you upgrade. For more information If you have any questions or comments about this advisory: Open an issue in next Email us at security@vercel.com

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-wr66-vrwm-5g5x

  2. Revision 1 · created ·

    Published from osv record GHSA-wr66-vrwm-5g5x

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2022-21721

Advisory: Denial of Service Vulnerability in next.js
IDs: CVE-2022-21721, GHSA-wr66-vrwm-5g5x
Record: https://patchnext.com/advisories/cve-2022-21721 (revision 2, source checked 26 Oct 2026, 12:30 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.9)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: next 12.0.9. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm next: affected >= 12.0.0, < 12.0.9; fixed in 12.0.9

## Suggested inspection (read-only)
- `npm ls next --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on next.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-wr66-vrwm-5g5x (OSV record GHSA-wr66-vrwm-5g5x lists affected ranges: npm next >=12.0.0 <12.0.9 (fixed))
- Verified: https://github.com/advisories/GHSA-wr66-vrwm-5g5x (GitHub-reviewed advisory GHSA-wr66-vrwm-5g5x lists affected ranges: npm next >=12.0.0 <12.0.9)

Commands are suggestions: review each one before running it.

Loading voting…