Skip to content

← Actionable
Low, CVSS 3.4amended

Renderers can obtain access to random bluetooth device without permission in Electron

CVE-2022-21718GHSA-3p22-ghq8-v749

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (electron 17.0.0-alpha.6, 16.0.6, 15.3.5, 14.2.4, 13.6.6), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm electron

    Affected
    < 13.6.6>= 14.0.0-beta.1, < 14.2.4>= 15.0.0-beta.1, < 15.3.5>= 16.0.0-beta.1, < 16.0.6>= 17.0.0-alpha.1, <= 17.0.0-alpha.5
    Fixed in
    15.3.5, 17.0.0-alpha.6, 13.6.6, 16.0.6, 14.2.4

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
3.4 · CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:C/C:L/I:N/A:N
EPSS
  • CVE-2022-21718: 0.95% estimated exploitation activity in the next 30 days; percentile 61.16 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact This vulnerability allows renderers to obtain access to a random bluetooth device via the web bluetooth API if the app has not configured a custom select-bluetooth-device event handler. The device that is accessed is random and the attacker would have no way of selecting a specific device. All current stable versions of Electron are affected. Patches This has been patched and the following Electron versions contain the fix: 17.0.0-alpha.6 16.0.6 15.3.5 14.2.4 13.6.6 Workarounds Adding this code to your app can workaround the issue. For more information If you have any questions or comments about this advisory, email us at security@electronjs.org.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-3p22-ghq8-v749

  2. Revision 1 · created ·

    Published from osv record GHSA-3p22-ghq8-v749

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2022-21718

Advisory: Renderers can obtain access to random bluetooth device without permission in Electron
IDs: CVE-2022-21718, GHSA-3p22-ghq8-v749
Record: https://patchnext.com/advisories/cve-2022-21718 (revision 2, source checked 26 Oct 2026, 12:24 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Low (CVSS 3.4)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: electron 17.0.0-alpha.6, 16.0.6, 15.3.5, 14.2.4, 13.6.6. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm electron: affected < 13.6.6; >= 14.0.0-beta.1, < 14.2.4; >= 15.0.0-beta.1, < 15.3.5; >= 16.0.0-beta.1, < 16.0.6; >= 17.0.0-alpha.1, <= 17.0.0-alpha.5; fixed in 15.3.5, 17.0.0-alpha.6, 13.6.6, 16.0.6, 14.2.4

## Suggested inspection (read-only)
- `npm ls electron --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on electron.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-3p22-ghq8-v749 (OSV record GHSA-3p22-ghq8-v749 lists affected ranges: npm electron >=0 =14.0.0-beta.1 =15.0.0-beta.1 =16.0.0-beta.1 =17.0.0-alpha.1 <17.0.0-alpha.6 (fixed))
- Verified: https://github.com/advisories/GHSA-3p22-ghq8-v749 (GitHub-reviewed advisory GHSA-3p22-ghq8-v749 lists affected ranges: npm electron >=0 =14.0.0-beta.1 =15.0.0-beta.1 =16.0.0-beta.1 =17.0.0-alpha.1 <=17.0.0-alpha.5)

Commands are suggestions: review each one before running it.

Loading voting…