Twisted SSH client and server deny of service during SSH handshake.
CVE-2022-21716GHSA-rv6r-3f5q-9rgx
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (twisted 22.2.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI twisted
- Affected
- >= 21.7.0, < 22.2.0
- Fixed in
- 22.2.0
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-rv6r-3f5q-9rgx lists affected ranges: PyPI twisted >=21.7.0 <22.2.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-rv6r-3f5q-9rgx lists affected ranges: PyPI twisted >=21.7.0 <22.2.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 8.7 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N · score source
- EPSS
- CVE-2022-21716: 3.51% estimated exploitation activity in the next 30 days; percentile 89.22 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact The Twisted SSH client and server implementation naively accepted an infinite amount of data for the peer's SSH version identifier. A malicious peer can trivially craft a request that uses all available memory and crash the server, resulting in denial of service. The attack is as simple as nc -rv localhost 22 < /dev/zero. Patches The issue was fix in GitHub commit https://github.com/twisted/twisted/commit/98387b39e9f0b21462f6abc7a1325dc370fcdeb1 A fix is available in Twisted 22.2.0. Workarounds Limit access to the SSH server only to trusted source IP addresses. Connect over SSH only to trusted destination IP addresses. References Reported at https://twistedmatrix.com/trac/ticket/10284 Discussions at https://github.com/twisted/twisted/security/advisories/GHSA-rv6r-3f5q-9rgx For more information Found by vin01
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-rv6r-3f5q-9rgx
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-rv6r-3f5q-9rgx
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2022-21716 Advisory: Twisted SSH client and server deny of service during SSH handshake. IDs: CVE-2022-21716, GHSA-rv6r-3f5q-9rgx Record: https://patchnext.com/advisories/cve-2022-21716 (revision 3, source checked 26 Oct 2026, 13:27 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.7) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: twisted 22.2.0. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI twisted: affected >= 21.7.0, < 22.2.0; fixed in 22.2.0 ## Suggested inspection (read-only) - `python -m pip show twisted`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on twisted. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-rv6r-3f5q-9rgx (OSV record GHSA-rv6r-3f5q-9rgx lists affected ranges: PyPI twisted >=21.7.0 <22.2.0 (fixed)) - Verified: https://github.com/advisories/GHSA-rv6r-3f5q-9rgx (GitHub-reviewed advisory GHSA-rv6r-3f5q-9rgx lists affected ranges: PyPI twisted >=21.7.0 <22.2.0) Commands are suggestions: review each one before running it.
Loading voting…