Skip to content

← Actionable
High, CVSS 7.2

Authenticated remote code execution in October CMS

CVE-2022-21705GHSA-79jw-2f46-wv22

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (october/system 2.1.27, 1.1.10, 1.0.474), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Packagist october/system

    Affected
    < 1.0.474>= 1.1.0, < 1.1.10>= 2.0.0, < 2.1.27
    Fixed in
    1.1.10, 2.1.27, 1.0.474

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.2 · CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H
EPSS
  • CVE-2022-21705: 8.65% estimated exploitation activity in the next 30 days; percentile 95.12 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact An authenticated user with the permissions to create, modify and delete website pages can exploit this vulnerability to bypass cms.safemode / cms.enableSafeMode in order to execute arbitrary code. - This issue only affects admin panels that rely on safe mode and restricted permissions. - To exploit this vulnerability, an attacker must first have access to the backend area. Patches The issue has been patched in Build 474 (v1.0.474) and v1.1.10. Workarounds Apply https://github.com/octobercms/library/commit/c393c5ce9ca2c5acc3ed6c9bb0dab5ffd61965fe to your installation manually if unable to upgrade to Build 474 or v1.1.10. References Credits to: - David Miller For more information If you have any questions or comments about this advisory: - Email us at hello@octobercms.com

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-79jw-2f46-wv22

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2022-21705

Advisory: Authenticated remote code execution in October CMS
IDs: CVE-2022-21705, GHSA-79jw-2f46-wv22
Record: https://patchnext.com/advisories/cve-2022-21705 (revision 1, source checked 26 Oct 2026, 14:05 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.2)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: october/system 2.1.27, 1.1.10, 1.0.474. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist october/system: affected < 1.0.474; >= 1.1.0, < 1.1.10; >= 2.0.0, < 2.1.27; fixed in 1.1.10, 2.1.27, 1.0.474

## Suggested inspection (read-only)
- Packagist october/system: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on october/system.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-79jw-2f46-wv22 (GitHub-reviewed advisory GHSA-79jw-2f46-wv22 lists affected ranges: Packagist october/system >=0 =1.1.0 =2.0.0 <2.1.27)

Commands are suggestions: review each one before running it.

Loading voting…