Skip to content

← Actionable
Medium, CVSS 5.5amended

Incorrect Default Permissions in log4js

CVE-2022-21704GHSA-82v2-mx6x-wq7q

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (log4js 6.4.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm log4js

    Affected
    < 6.4.0
    Fixed in
    6.4.0

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
5.5 · CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N
EPSS
  • CVE-2022-21704: 0.30% estimated exploitation activity in the next 30 days; percentile 22.50 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact Default file permissions for log files created by the file, fileSync and dateFile appenders are world-readable (in unix). This could cause problems if log files contain sensitive information. This would affect any users that have not supplied their own permissions for the files via the mode parameter in the config. Patches Fixed by: https://github.com/log4js-node/log4js-node/pull/1141 https://github.com/log4js-node/streamroller/pull/87 Released to NPM in log4js@6.4.0 Workarounds Every version of log4js published allows passing the mode parameter to the configuration of file appenders, see the documentation for details. References Thanks to ranjit-git for raising the issue, and to @lamweili for fixing the problem. For more information If you have any questions or comments about this advisory: Open an issue in logj4s-node Ask a question in the slack channel Email us at gareth.nomiddlename@gmail.com

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-82v2-mx6x-wq7q

  2. Revision 1 · created ·

    Published from osv record GHSA-82v2-mx6x-wq7q

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2022-21704

Advisory: Incorrect Default Permissions in log4js
IDs: CVE-2022-21704, GHSA-82v2-mx6x-wq7q
Record: https://patchnext.com/advisories/cve-2022-21704 (revision 2, source checked 26 Oct 2026, 12:30 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: log4js 6.4.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm log4js: affected < 6.4.0; fixed in 6.4.0

## Suggested inspection (read-only)
- `npm ls log4js --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on log4js.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-82v2-mx6x-wq7q (OSV record GHSA-82v2-mx6x-wq7q lists affected ranges: npm log4js >=0 <6.4.0 (fixed))
- Verified: https://github.com/advisories/GHSA-82v2-mx6x-wq7q (GitHub-reviewed advisory GHSA-82v2-mx6x-wq7q lists affected ranges: npm log4js >=0 <6.4.0)

Commands are suggestions: review each one before running it.

Loading voting…