Skip to content

← Actionable
Medium, CVSS 5.1amended

Improper Access Control in Onionshare

CVE-2022-21695GHSA-99p8-9p2c-49j4

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (onionshare-cli 2.5), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
5.1 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:A/VC:L/VI:N/VA:N/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2022-21695: 0.86% estimated exploitation activity in the next 30 days; percentile 58.44 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Between September 26, 2021 and October 8, 2021, Radically Open Security conducted a penetration test of OnionShare 2.4, funded by the Open Technology Fund's Red Team lab. This is an issue from that penetration test. - Vulnerability ID: OTF-009 - Vulnerability type: Improper Access Control - Threat level: Low Description: Authenticated users (or unauthenticated in public mode) can send messages without being visible in the list of chat participants. Technical description: Prerequisites: - Existing chatroom - Access to the chatroom (Public or known Private Key) - Either a modified frontend client or manual requests from burp/curl If a user opens the chatroom without emitting the join message he will not be present in session.users[x] list. Therefore there is no listing in the frontend and no chat participant knows another party joined the chat. It is still possible to send messages in the chatroom. If a user decides to abuse OTF-003 (page 22) he can impersonate messages from existing…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-99p8-9p2c-49j4

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-99p8-9p2c-49j4

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2022-21695

Advisory: Improper Access Control in Onionshare
IDs: CVE-2022-21695, GHSA-99p8-9p2c-49j4
Record: https://patchnext.com/advisories/cve-2022-21695 (revision 3, source checked 26 Oct 2026, 13:21 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: onionshare-cli 2.5. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI onionshare-cli: affected >= 2.3, < 2.5; fixed in 2.5

## Suggested inspection (read-only)
- `python -m pip show onionshare-cli`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on onionshare-cli.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-99p8-9p2c-49j4 (OSV record GHSA-99p8-9p2c-49j4 lists affected ranges: PyPI onionshare-cli >=2.3 <2.5 (fixed))
- Verified: https://github.com/advisories/GHSA-99p8-9p2c-49j4 (GitHub-reviewed advisory GHSA-99p8-9p2c-49j4 lists affected ranges: PyPI onionshare-cli >=2.3 <2.5)

Commands are suggestions: review each one before running it.

Loading voting…