Incorrect Permission Assignment for Critical Resource in OnionShare
CVE-2022-21694GHSA-h29c-wcm8-883h
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (onionshare-cli 2.5), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI onionshare-cli
- Affected
- >= 2.2, < 2.5
- Fixed in
- 2.5
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-h29c-wcm8-883h lists affected ranges: PyPI onionshare-cli >=2.2 <2.5 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-h29c-wcm8-883h lists affected ranges: PyPI onionshare-cli >=2.2 <2.5
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 5.3 · CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:L/VA:N/SC:N/SI:N/SA:N · score source
- EPSS
- CVE-2022-21694: 1.26% estimated exploitation activity in the next 30 days; percentile 69.62 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Between September 26, 2021 and October 8, 2021, Radically Open Security conducted a penetration test of OnionShare 2.4, funded by the Open Technology Fund's Red Team lab. This is an issue from that penetration test. - Vulnerability ID: OTF-006 - Vulnerability type: Broken Website Hardening Control - Threat level: Low Description: The CSP can be turned on or off but not configured for the specific needs of the website. Technical description: The website mode of the application allows to use a hardened CSP, which will block any scripts and external resources. It is not possible to configure this CSP for individual pages and therefore the security enhancement cannot be used for websites using javascript or external resources like fonts or images. If CSP were configurable, the website creator could harden it accordingly to the needs of the application. As this issue correlates with the Github issue for exposing the flask application directly (https://github.com/onionshare/…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-h29c-wcm8-883h
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-h29c-wcm8-883h
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2022-21694 Advisory: Incorrect Permission Assignment for Critical Resource in OnionShare IDs: CVE-2022-21694, GHSA-h29c-wcm8-883h Record: https://patchnext.com/advisories/cve-2022-21694 (revision 3, source checked 26 Oct 2026, 13:21 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: onionshare-cli 2.5. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI onionshare-cli: affected >= 2.2, < 2.5; fixed in 2.5 ## Suggested inspection (read-only) - `python -m pip show onionshare-cli`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on onionshare-cli. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-h29c-wcm8-883h (OSV record GHSA-h29c-wcm8-883h lists affected ranges: PyPI onionshare-cli >=2.2 <2.5 (fixed)) - Verified: https://github.com/advisories/GHSA-h29c-wcm8-883h (GitHub-reviewed advisory GHSA-h29c-wcm8-883h lists affected ranges: PyPI onionshare-cli >=2.2 <2.5) Commands are suggestions: review each one before running it.
Loading voting…