Skip to content

← Actionable
Critical, CVSS 9.0

Server Side Twig Template Injection

CVE-2022-21686GHSA-mrq4-7ch7-2465

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (prestashop/prestashop 1.7.8.3), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
9.0 · CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:C/C:H/I:H/A:H
EPSS
  • CVE-2022-21686: 1.79% estimated exploitation activity in the next 30 days; percentile 78.35 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

PrestaShop is an Open Source e-commerce platform. Starting with version 1.7.0.0 and ending with version 1.7.8.3, an attacker is able to inject twig code inside the back office when using the legacy layout. The problem is fixed in version 1.7.8.3. There are no known workarounds.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-mrq4-7ch7-2465

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2022-21686

Advisory: Server Side Twig Template Injection
IDs: CVE-2022-21686, GHSA-mrq4-7ch7-2465
Record: https://patchnext.com/advisories/cve-2022-21686 (revision 1, source checked 26 Oct 2026, 14:05 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 9.0)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: prestashop/prestashop 1.7.8.3. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist prestashop/prestashop: affected >= 1.7.0.0, <= 1.7.8.2; fixed in 1.7.8.3

## Suggested inspection (read-only)
- Packagist prestashop/prestashop: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on prestashop/prestashop.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-mrq4-7ch7-2465 (GitHub-reviewed advisory GHSA-mrq4-7ch7-2465 lists affected ranges: Packagist prestashop/prestashop >=1.7.0.0 <=1.7.8.2)

Commands are suggestions: review each one before running it.

Loading voting…