Skip to content

← Actionable
Medium, CVSS 5.1amended

Comment reply notifications sent to incorrect users

CVE-2022-21683GHSA-xqxm-2rpm-3889

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (wagtail 2.15.2), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI wagtail

    Affected
    >= 2.13, < 2.15.2
    Fixed in
    2.15.2

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
5.1 · CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:P/VC:L/VI:N/VA:N/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2022-21683: 0.97% estimated exploitation activity in the next 30 days; percentile 61.92 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact When notifications for new replies in comment threads are sent, they are sent to all users who have replied or commented anywhere on the site, rather than only in the relevant threads. This means that a user could listen in to new comment replies on pages they have not had editing access to, as long as they have left a comment or reply somewhere on the site. Patches A patched version has been released as Wagtail 2.15.2 (for the current LTS), which restores the intended behaviour - to send notifications for new replies to the participants in the active thread only (editing permissions are not considered). Workarounds New comments can be disabled by setting WAGTAILADMINCOMMENTSENABLED = False in the Django settings file. Acknowledgements Many thanks to Ihor Marhitych for identifying this issue. For more information If you have any questions or comments about this advisory: Visit Wagtail's support channels Email us at security@wagtail.io (if you wish to send encrypted email, the…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-xqxm-2rpm-3889

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-xqxm-2rpm-3889

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2022-21683

Advisory: Comment reply notifications sent to incorrect users
IDs: CVE-2022-21683, GHSA-xqxm-2rpm-3889
Record: https://patchnext.com/advisories/cve-2022-21683 (revision 3, source checked 26 Oct 2026, 13:27 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: wagtail 2.15.2. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI wagtail: affected >= 2.13, < 2.15.2; fixed in 2.15.2

## Suggested inspection (read-only)
- `python -m pip show wagtail`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on wagtail.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-xqxm-2rpm-3889 (OSV record GHSA-xqxm-2rpm-3889 lists affected ranges: PyPI wagtail >=2.13 <2.15.2 (fixed))
- Verified: https://github.com/advisories/GHSA-xqxm-2rpm-3889 (GitHub-reviewed advisory GHSA-xqxm-2rpm-3889 lists affected ranges: PyPI wagtail >=2.13 <2.15.2)

Commands are suggestions: review each one before running it.

Loading voting…