Inefficient Regular Expression Complexity in marked
CVE-2022-21681GHSA-5v2h-r2cx-5xgj
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (marked 4.0.10), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm marked
- Affected
- < 4.0.10
- Fixed in
- 4.0.10
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-5v2h-r2cx-5xgj lists affected ranges: npm marked >=0 <4.0.10 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-5v2h-r2cx-5xgj lists affected ranges: npm marked >=0 <4.0.10
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- EPSS
- CVE-2022-21681: 2.77% estimated exploitation activity in the next 30 days; percentile 86.32 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact What kind of vulnerability is it? Denial of service. The regular expression inline.reflinkSearch may cause catastrophic backtracking against some strings. PoC is the following. Who is impacted? Anyone who runs untrusted markdown through marked and does not use a worker with a time limit. Patches Has the problem been patched? Yes What versions should users upgrade to? 4.0.10 Workarounds Is there a way for users to fix or remediate the vulnerability without upgrading? Do not run untrusted markdown through marked or run marked on a worker thread and set a reasonable time limit to prevent draining resources. References Are there any links users can visit to find out more? - https://marked.js.org/usingadvanced#workers - https://owasp.org/www-community/attacks/RegularexpressionDenialofService-ReDoS For more information If you have any questions or comments about this advisory: Open an issue in marked
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-5v2h-r2cx-5xgj
- Revision 1 · created ·
Published from osv record GHSA-5v2h-r2cx-5xgj
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2022-21681 Advisory: Inefficient Regular Expression Complexity in marked IDs: CVE-2022-21681, GHSA-5v2h-r2cx-5xgj Record: https://patchnext.com/advisories/cve-2022-21681 (revision 2, source checked 26 Oct 2026, 12:29 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: marked 4.0.10. A vendor fix does not mean a deployment is fixed. ## Affected components - npm marked: affected < 4.0.10; fixed in 4.0.10 ## Suggested inspection (read-only) - `npm ls marked --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on marked. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-5v2h-r2cx-5xgj (OSV record GHSA-5v2h-r2cx-5xgj lists affected ranges: npm marked >=0 <4.0.10 (fixed)) - Verified: https://github.com/advisories/GHSA-5v2h-r2cx-5xgj (GitHub-reviewed advisory GHSA-5v2h-r2cx-5xgj lists affected ranges: npm marked >=0 <4.0.10) Commands are suggestions: review each one before running it.
Loading voting…