Skip to content

← Actionable
Medium, CVSS 6.5amended

Potential exposure of tokens to an Unauthorized Actor

CVE-2022-21671GHSA-7w54-gp8x-f33m

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (@replit/crosis 7.3.1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
6.5 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N
EPSS
  • CVE-2022-21671: 0.97% estimated exploitation activity in the next 30 days; percentile 62.02 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact When using this library as a way to programmatically communicate with Replit in a standalone fashion, if there are multiple failed attempts to contact Replit through a WebSocket, the library will attempt to communicate using a fallback poll-based proxy. The URL of the proxy has changed, so any communication done to the previous URL could potentially reach a server that is outside of Replit's control and the token used to connect to the Repl could be obtained by an attacker, leading to full compromise of that Repl (not of the account). Patches This was patched in 7.3.1, by updating the address of the fallback WebSocket polling proxy to the new one. Workarounds Specify the new address for the polling host (gp-v2.replit.com) in the ConnectArgs: For more information Thanks to https://hackerone.com/orlserg for disclosing this. If you have any questions or comments about this advisory: Open an issue in replit/crosis Email us at security@replit.com

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-7w54-gp8x-f33m

  2. Revision 1 · created ·

    Published from osv record GHSA-7w54-gp8x-f33m

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2022-21671

Advisory: Potential exposure of tokens to an Unauthorized Actor
IDs: CVE-2022-21671, GHSA-7w54-gp8x-f33m
Record: https://patchnext.com/advisories/cve-2022-21671 (revision 2, source checked 26 Oct 2026, 12:24 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: @replit/crosis 7.3.1. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm @replit/crosis: affected < 7.3.1; fixed in 7.3.1

## Suggested inspection (read-only)
- `npm ls @replit/crosis --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on @replit/crosis.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-7w54-gp8x-f33m (OSV record GHSA-7w54-gp8x-f33m lists affected ranges: npm @replit/crosis >=0 <7.3.1 (fixed))
- Verified: https://github.com/advisories/GHSA-7w54-gp8x-f33m (GitHub-reviewed advisory GHSA-7w54-gp8x-f33m lists affected ranges: npm @replit/crosis >=0 <7.3.1)

Commands are suggestions: review each one before running it.

Loading voting…